Posting forums is sometimes inaccessible? with jaws? and with iPhone?

Sometimes when I try to post forums it seems as if it is inaccessible both with jaws and with voiceover on the iPhone. I can sometimes write a subject, but when it gets to the body element it is a little difficult, because before I write I must disable rich text because it throws the screen readers off. I see that when choosing a format to write with there are only 2 options and both of them seem to act the same. Is it possible if there was just subject, forum choice, body and submit? Rather than having to deal with formatting options? like underlining and italics and bold? I hope this can get fixed (apple vis editors)

Forum: 

#1 Posting Issues

Member of the AppleVis Editorial Team

Hi Juan, We are aware of the difficulties some users are experiencing when posting to the forums from an iOS device, and we are working on getting those issues resolved. What kind of problems are you encountering when trying to post using JAWS? What version are you using? Thanks, Michael Hansen AppleVis Editorial Team

#2 JAWS and voice over inaccessible? not for me

I've never had a problem with any of the aeas of this website using JAWS and I'm using the latest JAWS 14 version. I never worry about using any specific texst, Ijust write my comment and submit it. I've not tried it using my iPhone but probably should just to test it out.

#3 Known problems on iOS

Member of the AppleVis Editorial Team

As Michael said, I am aware of inconsistent behavior when posting to the site from an iOS device. This is most noticeable when trying to swipe between input fields. Using the Next and Previous buttons above the onscreen keyboard does seem a little more reliable, but still shows problems. Unfortunately, I've not been able to resolve this yet. The problem is not specific to this site, as I have encountered it on every other site that I've checked which is running the same software (there are tens of thousands of sites that use the software). This includes the home page for the software itself. Right now, I am unclear as to whether it is a problem with the website software or iOS, and am trying to get some answers from the developers of the software. So, unfortunately you will all need to bear with us until we find a fix.