iOS 9.2, iPhone 6s: Notifications are broken with voiceover

Hi
So, For god's sake... I don't know why the latest flagship with the latest operating system available for that flagship should have a huge bug like this. I basically can't hear my notification with VoiceOVer when it comes through. I just have to go pick it up and touch it to find out what it is.
When i get a notification, This is all I hear:
"Hooks, now, tech crunch: Amazon decides t.... 2 notifications.... 5 44 PM."
Or
"Message from Darius: Hey when's th. one notification. 5 44 PM."
Like... seriously. I think this is also happenning to apple watch as well, If you raise your hand and touch the screen, It breaks like this.
Are you guys having the same problem or I'm being cursed?
Thanks

Forum: 

Odd…

I have noticed since not only purchasing the 6S, but obviously it came with iOS nine preinstalled, that I will hear a notification alert but voiceover will not speak anything on the screen unless I pick my phone up. In iOS 8 on my 5S, as soon as a notification would come in I would hear the alert sound, followed by what time it was, what kind of notification it was, the words one new notification, the time again, and then screen locked. I didn't like that this would happen every time I got a notification… I prefer how iOS 9 is set up. If you are not getting your alert sounds at all, then there is most likely a setting that either was accidently disabled or enabled, or a hardware malfunction. I don't think this issue is a software bug like the last person mentioned. Some people accidently turn their phone on mute using the switch on the side of the device without knowing, so that would probably be the first place I would check. If you normally have vibrate always on, as in every time you receive a notification your device will vibrate as well as give you an alert sound, but yet you are currently not receiving any vibrations or alert sounds… Then as the above person mentioned, you may have possibly enabled do not disturb mode at some point. If do not disturb mode is enabled, you can either simply tell Siri to disable do not disturb mode, and she will give you feedback whether she was able to turn it off, or if it was not on she would tell you that it was not on. Otherwise if do not disturb mode is in fact on, there will be a icon for it in the status bar between the time and battery. I believe it is labeled as do not disturb mode, and it's a little moon if you can see at all.

Yeah but

Yeah but, even if they had their phone on mute, the notification still would be spoken by voice over when the iPhone was locked.

Not necessarily…

At least for me, since getting my 6S as well as having iOS 9, voiceover does not automatically speak any information on my lock screen when a notification is received. I get the alert sound, and a vibration, as well as my screen does unlock, but unless I pick my phone up voiceover will not speak any of the information on the screen automatically. I'm not sure if this is a feature Apple changed with iOS 9, or if it's an upgraded accelerometer feature of the 6S, nor have I asked anyone else if this is the case for them as well, no matter what device they are using with iOS 9. I'm only speaking from my experience! Also, I remember that with my 5S using iOS 8, if my phone was muted, voiceover would not automatically speak anything from my lock screen upon receiving a notification. But once I unmuted my phone, as soon as I received the next notification to my lock screen, voiceover would then read all of the information I stated in my last comment. But like I said, that was with iOS 8, and that does not happen with my 6S running iOS 9.2.

That's weird

That's weird. Try emailing Apple accessibility, and see what they respond about this. It could be that it is a feature as the previous poster said.

When we have protective case

When we have protective case with a lid, then the alerts are not reported. When the lid is open communicated regularly.

IPad cases

If you have an iPad, then a cover or case will cause the iPad to lock as you close the cover, then unlock when you open it.

If you lock the iPad with the cover or case, then the screen will not come on when notifications are received, so you will only get the notification sound, no VoiceOver announcements.

On the other hand, if you lock the iPad with the sleep/wake button and leave the case open, then the screen will light up with each notification, causing VoiceOver to announce the notification immediately.

As far as I know, iPhones do not have anything like this, and the lock screen always comes up when notifications are received regardless. Maybe this is different for newer iPhones, but I am not aware of anything like it.

I personally don't like it when notifications are automatically announced, especially since the end of the notification tends to get truncated. This is why I like the iPad behavior described above, and it is also why I turned off banner notifications for each app in the notification settings. Let me know with a sound when a notification arrives, then let me check out the notification itself when it is convenient for me. That is how I like it personally.

That

I haven't had that experience.

That

I haven't had that experience.

That

I haven't had that experience.

Alert notifications

I get alert sounds intermittent for messages and others apps , always get alert for incoming calls , I'm so excited when it works , buts that's only been 3 times , hope next update fixes this !

Some things to try.

I haven't noticed this issue in 9.3.1 so maybe it got fixed but go to Voiceover settings and make sure that always speek notifications is on. Also it would make sence that voiceover wouldn't speek notifications when muted so that your phone doesn't start talking randomly when you're in class or a meeting.