Is Safari 6.1 alright on Mountain Lion?

Hi all, I am currently still running Mountain Lion and am wondering for those who have updated to the latest Safari V6.1 How are you finding it to be with Voiceover? Has it broken anything? Is it faster? I just want to be sure before I update. Thanks Daniel

Forum: 

#1 I'm having issues

Hi, When I updated I immediately noticed some default preferences were changed and that was annoying but I put them back and then reset Safari and cleared caches because Safari was slow. That helped and I thought everything was fine until I did some shopping on Amazon. I don't know if it's changes in Amazon or the new Safari but sometimes product pages are reloading. I'm a heavy Amazon user so this is annoying. I haven't really noticed issues anywhere else though. HTH.

#2 Didn't like it

I updated to 6.1 and I totally hated it. If you use the rotor list, VO keys plus U, the headings show are half or less than the ones appearing in the page. The window has also changed but you may like it or not. One last change, when you're on a web page and there are some flash or java items, but you don't use them Safari disables them to keep resources.

#3 infinite loop

the infinite loop syndrome affects both safari 7.0 in mavericks and 6.1 in mountain lion. rather than restoring to older version of safari like i did with mavericks, i stick with the new version of safari and hope the problem will get fixed soon. the reason is the new safari contains security updates. i don't know about you, but safari is the most used app on my mac, i use it all day long. i just can't afford not to patch security holes whenever possible.

#4 Oh man, reloading explained, thanks

I thought I was going crazy on Amazon. I swear I hear the word "snake" and then the dang page reloads. I'm a heavy Amazon user so this is awful! You think it will get fixed soon? Man I hope so. So glad you posted that.

#5 links repeating with Wikipedia

Hi all, since updating to Safari 6.1 running Mountain Lion. Have noticed that links are repeated regardless of say all or normal navigation with the VO keys. Can anyone confirm? also, is there anything I can do about it? Its like really annoying. :(