voiceover speaking with 2 different voices after upgrading to mac OS mojave

Hi all, Before upgrading to mac os mojave, the selected voice over voice was scottish fiona. I like to change the voices from time to time. anyway, after upgrading, I now have the scottish voice and australian Karen both saying different things. for example, the scottish voice says: "desktop macintosh HD." but australian voice says "volume" the scottish voice will speak the doc, but as soon as I load an app or the home folder it switches to the australian voice. How do I make one voice speak everything please? Thanks in advance and your help is much appreciated. :)

Forum: 

#1 VoiceOver utility

Hi
I ran into the same problem. You can set up what voice speaks what in the VoiceOver utility in the speech category.
Click the edit button on English, then expand the disclosure triangle for additional options. Here you can set different voices for different contexts.

Best
Malthe

#2 Thank you it worked!

Thanks heaps. Is this something introduced in the new upgrade? never seen this before.

#3 Hi

Hi
Glad it worked for you too! I don't think it's new, but it's the first time I experienced the bug where VoiceOver randomly reassigns the voices.

Best
Malthe

#4 Thanks!

You saved my life with this post and answer! I updated to 10.13.6 and suddenly my Portuguese voice started to say "button" and "tool bar" in slow motion when Samantha was selected, thanks a lot :)

#5 More on the above issue changing voices

Hi Again Malthe, I changed to another voice, and this time it was speaking some things with the new voice but since I'd changed the default voice to the scottish voice, it still spoke some things with that voice and other things with the new voice. I have changed it back to the default scottish voice as I had only changed the voice for demo purposes, but if I want to change the voice in future, is there a way to have it so that no matter what voice you change it too, it speaks everything in the new voice. When I say change voices I'm doing it by pressing control, option, command, shift, then up or down arrow depending on which way I want to go.

#6 Regarding universally changing voice

@Andrew90 When you click the edit button in the language table, and you get to the voices screen, you can set the pop-up buttons for the other voices to "default". In my mind, that should make it follow along when you subsequently switches with the rotor. Does that work for you? Unfortunately I'm not at home right now, so I can't test.

Best
Malthe

#7 sure did work

Thanks again Malthe, sorry for late reply only just tested it this afternoon, but can confirm I changed everything to default and when I changed from scottish to Australian, everything was spoken in the australian voice. :) Have a great day. :)