Awkward pronunciation problem in IOS 6

First off, I use my iPhone bilingually; Dutch and English. Dutch being the main language the iPhone is set to and English accessed via the language rotor. I had a bit of a shock after installing IOS 6. What happened was that the Dutch voice seemed to take on English pronunciation rules, giving me a rather muddled and odd experience. After doing a reboot the pronunciation seemed to be back the way I was used to, until I used an app that didn't support Dutch, so automatically defaulted to English. When switching back to the Dutch voice the pronunciation issues were back. Not very impressed I set my iPhone to English as the main language and Dutch accessed through the rotor. This gives me the compact Dutch voice, which I'm not very happy about, however, no pronunciation issues have occurred since then. Apple accessibility is aware of the issue and is working on it. However they can't give an estimate when it'll be fixed, due to its specific nature.. I am aware that most of you speak English as your first language, so wouldn't run into this issue. However, I felt it was necessary to post this as it would've been a serious deal breaker were I not fluent in English. Did anyone else who has their iDevice set to a non-English language experience this issue?

Forum: 

Try the following to solve the problem

1. Go to the Language Rotor setting. 2. Check Dutch, I think it is not checked on your iDevice. Although it seems that it is unnecessary, because your rotor already have a "default" setting which is Dutch, check your language in the rotor settings, I'll explain why. 3. Close the Settings App. 4. Now, your rotor has at least 3 items: Default, English, Dutch. 5. Choose Dutch in the rotor, and VO will speak in Dutch even if an application doesn't support your language natively. Explanation: In iOS 6, Automatic Language switching is extended to apps. In earlier versions, VO used automatic language switching in web contents only. Now, if you open an app that reports "I'm an English language application" to the OS even if its interface is localized to other languages, VO will switch to english. To verify an app's UI language setting, open the app and tap the status bar at the top of the screen. Tap the Battery icon for example. If the icon label is in your language, the app UI language setting is OK. If in English, and the app has a Dutch UI interface for example, the UI language setting is wrong. You can use the steps above to tell VO: Please don't use automatic language switching.

I followed the steps as

I followed the steps as outlined in the post, but it still gave me the same issues I had before, regardless whether I used the non-default Dutch setting in the language rotor. In fact, both the default and non-default Dutch were similarly affected. I switched my phone back to English to avoid this annoyance till Apple sorts it out.

It seems that this is a real bug in Dutch localization

My phone is set to Hungarian, and I'm not experiencing this problem. However, I had to check Hungarian in the Language Rotor to disable automatic language switching. I'm sorry that this doesn't solve your problem.

Dutch localization problem

Yes, it happened here too. An alternative is to switch the regional settings to Belgium, in which case you get Ellen, who still speaks dutch normally. To any dutch users wondering what the new dutch pronounciation sounds like, I have made a recordingthat is available on this link: https://dl.dropbox.com/u/10143565/xanderinios6.mp3. Just like steenwolf I have switche to English for now. Kind regards, Henk.

Hi, I am having exactly the

Hi, I am having exactly the same issue after upgrading to ios 6. I switched my iPhone 4S to English for now, but hopefully Apple will fix this problem right away. I think this is a big sho stopper for Dutch people who don't speak English very well or use a lot of Dutch apps because both the compact Dutch and Belgium voices are of much lower quality compared to the premium Dutch voice.

I've already mailed them

I've already mailed them about it yesterday. I'd also urge anyone experiencing this issue to mail accessibility@apple.com.