Cannot connect to server, 1004

I have the MacBook Air released this year. Ever since the last update to Sierra, I've had an OS update that won't finish. I initially had the same problem with the update to Sierra, but I was eventually able to get it to work. But everytime I try to update "Remote Desktop Client Update" to version 3.9.3, I get, "An error has occurred. Could not connect to the server, 1004. I've tried every fix I could find on Google. Other apps have updated, and I have Internet, so I don't think it's the connection. When I try to connect the MacBook to the Internet using my phone's connection, the update times out, and I get a different error.

Forum: 

#1 Hmm, I can't think of

Hmm, I can't think of anything except for maybe something on there end that is causing the issue. Maybe try getting in contact with apple and giving the issue/steps you are taking and see what they say?

#2 Something you can try...

Hello,

Since the update is part of the app store, I would try the suggestion here.
https://discussions.apple.com/docs/DOC-4293

Personally, I haven’t seen this error so I can’t say for certain the above will work. If you feel uncomfortable trying that, you can try calling apple support.

HTH and good luck.

#3 Thanks!

Thanks for the suggestion. I tried that, and unfortunately it didn't work. Looks like it's time to give Apple a call.