Can't place a call using SIRI

Hi,
This question might have been asked years ago but I never found any solution to this problem...
First of all, I'm living in Southern Africa, in a very small country called The Kingdom of Swaziland, country code 268, If I ask Siri to call someone, it looks like it's working, but the process always stop saying "Sorry I can't call ABC on this number" (where ABC is the name of the person I want to call)... This problem exists since my first iPhone, 4 years ago. And none of the successive versions of iOS fixed it...
Does anyone have a potential solution? I did try adding zeros after my numbers to get a 10 digits number as it is suggested on some forum, but it did not sort the issue out.
Thanks for your eventual suggestions.

Forum: 

#1 Is Siri available in your country?

Hello,
This might be a country specific issue. For instance, if you use the UK version of Siri in the United States, some functionality might not work perfectly fine. This is why Apple only supports Siri in certain languages and countries. It's not just because of the voice or accent. For instance, the voice used for Siri in the US and Canada is exactly the same, but they have their own separate country selections. I really don't know how to explain it, but for some reason, I think this might be causing the issue. I've only encountered this issue when trying to call an international number, and surprisingly, when trying to call Apple's accessibility number, which is located here in the States.

#2 Get your point...

Thanks for your answer...
I don't think Siri will ever support Swaziland, considering that it is still not supporting South Africa or any country in Africa. Apple should rather use the phone number stored inside my contact list (like they are apparently doing when Siri is sending a SMS instead of using a country code when dialling)! On my previous iPhone (4), using the standard voice command, I was able to call someone... Maybe they should add an option in Siri configuration that says "use the phone numbers as they are stored in my contacts list" to solve this issue,
Again, thanks for your reply.

#3 Can't make calls using Seri

I have no idea if this will make a difference, but have you tried toggling "Dial Assist" off or on? It is in Settings>Phone near the bottom.
Hth,
June I.

#4 Strange...

Hi, I think it might be the solution to my problem, unfortunately... I can't find the option "dial assist" in "setting > Phone"!?

#5 Hmmm...

Hello,

What version of the IOS are you using?

On my iPhone 6 with IOS 8.3, I go to settings then phone. From there, be sure your number is shown correctly in my number box. In my case, I am in the USA so the box shows, 1 818 450 0000. Well, that’s not my number but just to give you an example. Then look down a bit and you will find the dial assist on or off. Turn it on. Once this is done, check the contact you are trying to call. Make sure the number is shown correctly without the country code.

HTH and good luck.

#6 Dial assist missing in Settings > Phone

Hi David,
Thanks for your post, and for everyone's posts... The field My Number shows +26876xxxxxx where 268 is my country code and 76xxxxxx is my phone number... I tried to remove the + sign but it didn't change anything : Dial Assist doesn't appear in Setting > Phone.
I'm running iOS 8.3 on an iPhone 5s.
I checked on my wife's iPhone 4 in iOS 7.1 and I can't find this option neither.
I'm still certain that this is the solution to my issue,
Cheers.

#7 Odd.

Hello,

That’s odd. Since it’s on two different versions of IOS, I suspect it’s country/region specific.

So if you go to contacts and double tap a number, does it go through? Have you tried asking Siri to dial the number specifically and not by a contact name? Instead of saying “call ABC” say “dial 123456789”

#8 It's a SIRI / country issue

Hi,
Yes I did try this...

If I double-tap on a phone #, it works normally (but if it wasn't I think that I might not be an iPhone user).
I get the very same error if I say "dial 76666666"

I found something on an indian blog, where someone says that he had to take the SIMM card out to get this option back in Settings > Phone, arguing that some settings from the network operator can affect this option... I will ask someone to help me in order to check it.

I have also contacted the local network operator (MTN) and asked them to assist, They did not look that sure about it and they are going to check on their side... At least now I know that there is an option DIAL ASSIST that, I'm sure. just need to be turned off, as it looks like doing exactly what I was suggesting by disabling the country code when toggled off.

Thanks for your help...

#9 same problem

Hi Laurent, did you ever find a solution to the siri not dialling problem? I'm also in Swaziland and have the same issue. I also cant find the Dial Assist option. I've got an Iphone 5, using ios8.3 as you say, really frustrating! The only numbers siri will dial are international. cheers.

#10 calling with siri

Its working just fine here.

#11 Not yet...

Hi Matt,

I found this link: https://discussions.apple.com/thread/5291491

But maybe I'm not fast enough to do the proposed manipulation in the forum above to find the option DIAL ASSIST when removing and putting the SIMM card back? Can you try it on your side and tell me if you are able to get the option before the phone detects the network?

MTN has apparently no answer to our problem,,,

Thanks for your help.
Laurent.

#12 eish, I tried this but it

eish, I tried this but it does not work; there is no Dial Assist showing anywhere. I guess we wait another decade for Apple to recognize Swaziland as a country? Google Earth at least recognised us for the first time last year!

#13 not a Siri feature

I may be wrong, but having the phone call a person in your contacts list or calling a phone number is not a Siri function. If you press and hold the home button and give the verbal instruction to "Call Joe", for example, I'm thinking this is a feature of the phone. At least, I'm sure that calling a phone number is a phone feature rather than a Siri feature.

#14 Re: not a Siri feature

Sadly, you are mistaken as this is actually a feature of Siri that we are dealing with and many people are actually experiencing it in some countries that aren't adequately recognised or possibly their phone providers. It's the interaction with Siri that falters and not the capability to make the phone call - which it obviously can through other means.

#15 Not Dial Assist

Hi Laurent,

I know you're looking at the Dial-Assist feature with plenty of hope, but sadly this is not the solution to your problem. We too have the same problem in Namibia and yes, it has yet to be fixed in 2017. My presumption is that Apple has certain agreements with mobile operators which might allow them to be fully recognised by them for such features. South Africa doesn't have this problem anymore since I know people there that use it all the time and I'm able to call to numbers in their country. They however, are unable to make calls to Namibian numbers, so I think there is a literal blockage of network operators who haven't been "approved" to properly sell iPhones on those respective networks and as such, their numbers could be silently barred from operating adequately on Apple's terms. This is just a guess of course...

#16 Good news from Swaziland.

Hi African-Techie,
Thank you so much for your post… I have just updated my iPhone to iOS 11 .1 and the good news is that since then, I can call using Siri. Hoping it’s going to work for you in Namibia soon
Matt, if you’re still in the country you might try to download 11.1.
Cheers.

#17 Congrats Swaziland

Hi Laurent,

That's good news and congrats. We will have to wait and see what happens in Namibia. Did you ever get that feature you were looking for showing in your phone's settings? Can you let me know if it's enabled/disabled? I too have been on iOS 11.1 from the moment it released (I'm a bit of an Apple obsessive chap) - but sadly, that hasn't done anything to help our plight.

Warm regards, and take care,

African-Techie

#18 I think you wear right…

Hi again… I think you were right in the sense that the option I was talking about earlier has never been available in my phone. The only difference between yesterday and The days before is that I have installed iOS 11.1. So I didn’t change anything in my phones configuration. I came straight from iOS 10.3.3 as I was a bit sceptical on the stability of iOS 11.0 Good luck and warm regards

#19 Thanks for the heads up

Thanks for the heads up Laurent; its working!!

#20 Wonderful…

Hi matt, that’s great! Now, let’s hope that the iPhone 8 will be here very soon at a fair price! Just joking!