Bluetooth AZERTY Keybord (both Amazon generic and Logitech Keys to go) problem to navigate by headings levels on IOS

Hardware & Accessories

Hi everyone,

Here is my first post. I am french and using IPhone 6 and Ipad mini but have a hard time using a bluetooth keyboard with them. I want to use less and less my computer and do the most of things on my Iphone an Ipad, and i would like to be able to fully workk on these devices.
To do so i need to be confident with a bluetooth keyboard. I have read and listened to some tutorials but still encounter troubles.
Navigating through headings levels using keys 1 tou 6 only works when pressing SHIFT at the same time, so i can only navigate down. I guess it is due to the fact that on azerty keyboards the row of keys below the Fonctions keys needs SHIDFT to be hold to type the numbers, else it types symbols and what we call in french language "accents" such as é or è....

DO someone know how to solve that?



Submitted by Justin on Monday, April 4, 2016

Hello and welcome to applevis! To navigate by heading using a BT keyboard, make sure that quicknav is on, by pressing the left and right arrows simultaneously or at the same time. Then use the "H" key to navigate by headings, L to navigate by links, etc. This is the best way to go from heading to heading that I've found.
Good luck!

Submitted by Adam Samec on Friday, August 12, 2016

Hello Smile,
I am experiencing the same issue with the Czech language keyboard which also behaves as you discribed concerning the way how numbers and some letters with accents are inserted on it.

However, I am able to navigate backwards by headings of a particular level using the keyboard shortcut: Option + number from 1 to 6. I hope it will do for you too.

Nevertheless, navigating by headings of a particular level (forward or backward) sometimes stops to work for me. I was not able to find out when this happen. But Quick Nav using the letter keys, such as H for headings, always work, so I usually fall back to it at least.

As for using a keyboard in a language other than English, the keyboard shortcuts are problematic in general. Sometimes, the key combination you need to press is same as on the English keyboard without respect to the characters it generates. Sometimes, you need to find out which key combination on your keyboard generates the same characters as those defined by a keyboard shortcut, which may differ from the key combination on the English keyboard. And the other times, a keyboard shortcut doesn't work at all. So this could also be a source of your troubles.


Let me correct what I've written here. I tried swwitching to the French keyboard and using Alt + number 1 through 6 to navigate backwards and it doesn't work. Actually, neither does it completely with the Czech keyboard. It works there only for these number keys: 2, 3, 4 and 6. The reason is that only these keys if combined with the Alt key generate the correct characters of the keyboard shortcut, that is, at sign, number sign, dollar sign and caret, respectively. For the heading levels 1 and 5 I have to press Shift + another keys located elsewhere far away on my keyboard.

Submitted by Jake on Monday, August 8, 2016

The root of the problem here is exactly what you suspected. Both iOS and MacOS interpret the characters rather than the actual keystrokes. So, to move by heading level 1 doesn't happen until you actually type a number 1, however you do it.
There are a couple of ways around this. One way is to change your keyboard layout to something that has numbers in their usual places. For French, the Canadian layout would be a nice compromise if you want to go this route; it's a qwerty layout however, not azerty. The second method is to find out which keys on your keyboard make the correct characters that would ordinarily be above the shifted numbers on most Apple layouts in your locale. For US English, for example, you'd look for:
Exclamation mark, at sign, number sign, dollar sign, percent sign, and caret. These correspond to shifted 1 through 6. If you know what these characters are on your keyboard layout, you can use them.

Submitted by Adam Samec on Thursday, August 11, 2016

In reply to by Jake

Hi Jake,

I can't completely confirm what you are saying.

As far as navigating by heading levels is concerned, you are right that the keyboard shortcuts are recognized when you type a number from 1 to 6 or the special characters you mentioned, however you do it, that is, you can use Shift or Option to type these characters. However, this is not the case with the keyboard shortcuts that use the VO key. For example, the keyboard shortcut for changing the label of the selected item is defined as: VO + slash, and even though I am able to type slash on the Czech keyboard by pressing Shift + the key next to the letter P, the keyboard shortcut is not recognized when I press this combination together with the VO key. But such VO keyboard shortcuts that contain characters which I can type without pressing Shift or Option work well.

Another thing is that sometimes keyboard shortcuts are actually redefined to match the current keyboard language. For example, the keyboard shortcut for going back and forward in the history in Safari is defined for the US English keyboard as Command + left bracket and Command + right bracket, respectively. And I am able to invoke these commands using the same keys on the Czech keyboard as on the US English keyboard, even though the characters generated by these keyes are different than left and right bracket. I think this is the right approach for keyboard shortcuts that contain non-alphabetical characters, because the keys that need to be pressed to generate the characters of a non-alphabetical keyboard shortcut originally designed for the US English keyboard are often located on other language keyboards at inconvenient or illogical places, or even more, some characters can't be generated at all. The bad accessibility of the discussed Quick Nav keyboard shortcuts for navigating by heading levels being the best example of awkwardness caused by not obeying this approach. All other iOS VoiceOver keyboard shortcuts I know about are also not redefined to match other keyboards, as opposed to the Mac OS ones which mostly are.

Therefore, when testing a keyboard shortcut with a non US English keyboard, for which one only knoes the definition with respect to the US English keyboard, one has to try out both possibilities: the key combination that generates the defined characters and the key combination that is the same as on the US English keyboard. And as I mentioned in my first comment, sometimes neither work, as is the case with the Czech keyboard and the VO command for changing the label of the selected item.


Submitted by Jake on Wednesday, August 10, 2016

What you're experiencing is most likely a problem known as in-key roll-over. This means that certain key combinations, if pressed together, don't register if they have too many keys on the same mechanism or circuit. Some keyboards, particularly cheaper ones, can't register more than two or three keys on a mechanism at one time and, additionally, cannot easily process different parts of the keyboard. As it's different with various keyboard models, I have no way to tell you exactly which keys don't register on yours.
A way you can verify this is to use VO's keyboard help, then press the hotkey. Do all the keys register? You'll know if they do if VoiceOver properly speaks all of them. If any keys don't speak as you're pressing the hotkey however, or speak when you've released some of them, you're being hit by a lack of roll-over support in your keyboard. If this is the case--and it sounds like it to me--the only solution is to get a different keyboard. It's a hardware, and not a software, problem.

Submitted by Adam Samec on Friday, August 12, 2016

In reply to by Jake

A possible lack of rollover support by my Bluetooth keyboard is not the cause of me not being able to invoke iOS VoiceOver keyboard shortcuts that contain special characters I can type only using the Shift or Alt key. It's probably an iOS issue because I tried connecting this keyboard to my MacBook and the same keyboard shortcuts worked well. Also, the keys were properly registered when testing in Mac OS VoiceOver keyboard help.

By the way, I don't know if this is normal, but VoiceOver keyboard help on iOS behaves quite strangely. The keys speak when being released, not pressed, except for Control, Alt, Command left and right arrows which speak twice, both when being pressed and released. But on Mac OS all keys on my Bluetooth keyboard speak only when being pressed.

My keyboard is Logitech K380.