Has anyone else encountered huge typing slowdowns in MacOS Apple Mail?

Club AppleVis Member

Hi fellow Mackers. Apple Support and Accessibility are stumped.

I have a 2016 Macbook Pro and a brand new iMac Pro, both with the latest MacOS, and both with the same problem. When I'm typing an e-mail or a reply in Apple Mail, there is a big delay between my typing and the words actually getting onto the screen or out of VoiceOver. I have to wait a hand full of seconds before I can read what I've typed or do anything with it. All I get is "busy busy busy" when I try to read or edit.

This problem also happens inn other applications with text fields, such as Pages, Safari and Text Edit, but only intermittently.

I contacted Apple about this last June, and since then I've spent over 31 hours on the phone with them, my Macbook Pro has gone to the shop 7 times, and Apple still doesn't know how to fix it. Note: this problem occurs whether VoiceOver is turned on or off.

Has anyone else had this happen? I'm a somewhat fast typist (around 80 words per minute), so if you're slow or average on a keyboard, you probably would never notice, but if you're faster, and if you have noticed, please let me know.

Boo Boo

Forum: 

No issues as of here, at

No issues as of here, at least not that one. I can type about 60 wpm and it stays with me. I hope the ram is not going on that machine It can't be as it is on ly 2 years old. Have you done a reinstalled of the OS maybe that might help?

Did you try a clean install

Did you try a clean install trashig all of your settings and apps? If you did that and it still is not working, I am learning tward a hardware problem as I'm not having the issue and it appers no one else is to. I'm using high sierra 10.13.2

Take care

I did

Club AppleVis Member

Alas, i did. I may very well be having a hardware problem but Apple shows no interest in agreeing with us.

MacMail Busy

Hi,

I am not sure whether this is the same thing at all, but I have the following experience with slow MacMail.
I sometimes receive emails from, ironically enough, an Australian Organisation that offers support, aid and assistance to the Visually Impaired.

Whenever one of these emails is in my MacMail Inbox, it kills performance of MacMail. Kills it dead. I constantly get Busy Busy Busy and overall performance is terrible.

It matters not whether I have the email open or not, it's very existence on my system seems to be the problem. Delete the email and MacMail returns to normal.

Should, however, I try to interact with the email and it will take many minutes of Busy to open. Longer if I try to reply or forward it. Weirdly enough, the email itself isn't actually very large, but there's something in it that upsets the system.

My solution, after reporting it to the Sender has simply been to unsubscribe from the list. No more emails, no more problem.

HTH

@SeaNoEvil00

That might just be it!

Club AppleVis Member

Thank you for letting me know about this. Could you provide the e-mail address or the Agency's name and location so I or Apple Support might contact them? Must ch, much obliged!

Bruce

Vision Australia

Hi,

The emails which caused my problems seem to stem from a wonderful organisation called Vision Australia. Typically, they are marketing emails, with links to sales of Aids for the Visually Impaired.

I wish in no way to damage the reputation of this fine Organization, or imply any wrong doing on their behalf. The fact that these emails do not have any impact on my Windows machine or IOS suggests that the problem may be local to MacMail, or even just my settings within MacMail.

I should add, however, that you original complaint noted similar problems within other Text Fields. This has not been my experience.

Best regards,

@SeaNoEVil00

Same exact thing

This exact thing is happening to me on my new iMac Pro and I cannot figure it out as well. Any success with this?

Happens to me all the time

Happens all the time on both my MacBook Pro from 2012 and my Mac Mini. I have sent Apple Accessibility several emails about this issue, but they only give me the usual canded reply in return. The best work-around I've found for resolving this when it happens, is to hit enter to jump to new line and then use the up arrow to get back to the line above where I was typing. In some emails this can end up creating numerous extra empty lines at the end of my email before I have finished typing, but those lines I of course just delete before sending it away. Hth :)

edit>substitution>text replacement

Club AppleVis Member

What ended up working for me was turning off edit>substitution>text replacement. After that, text entry returned to normal.