Apple should include a voice-over gesture to toggle JavaScript on and off

Most of the website I read regularly with voice-over have become practically unusable now, due to voice-over not interacting well with advertisements and having trouble loading the pages.
In some cases, voice-over completely shuts down and even using the reader mode is no guarantee of readability.
The only solution I found is to toggle JavaScript off, which you can do in the advanced section of Safari settings, however this comes with its own problems and I find myself having to constantly go back and forth to do this.
Now I can understand criticism for my view, after all websites do need advertisements in order to make money, however I would counter that for a completely blind user like myself the adverts are hardly going to persuade me to buy anything since I can't see what's been advertised and although sighted people might find adverts annoying, they can avoid them and still use the website as normal however voice-over completely crashes making those sites unusable for me and I would imagine, other visually impaired people.
That's why I imagine it to be a voice-over only gesture, so only those with a visual impairment would be able to use it.
Or perhaps someone could create a shortcut which would give the same effect.
Thoughts?

Forum: 

#1 Use Content Blockers

Club AppleVis Member

I am a heavy iPhone user. I browse different websites all the time.
Hardly ever do I find VoiceOver going silent while in Safari. And I never ever had to turn JavaScript off and on. So basically, I can‘t reproduce the problems you‘re describing.
That said: I might well be experiencing different versions of the websites you are looking at. That‘s because I have started using a content blocker.
While particularly focosed on removing ads, the content blocker does clean up many websites pretty well, while (in most cases) not degrading functionality.
And if you do want to restore any website to its full ad-filled glory, all you need to do is long-press the „reload“ button and select „reload without content blocker“ option.
Here‘s the link to the one I‘m using, though choices concerning blockers are nearly endless:
https://apps.apple.com/ch/app/purify-block-ads-and-tracking/id1030156203

#2 Um ,what?

I have not had any of these issues you're speaking of. Have you tried the regular fixing steps? Like rebooting device, closing down Safari permanently and re-opening, etc etc?