Minesweeper Deluxe has just been released!

Club AppleVis Member
iOS and iPadOS Gaming

I wrote this to clear my brain of the dreaded KC
i will go back to it hopefully with a fresh look at the code.
This game was written as i like playing minesweeper and could not find a version i liked or could
play without the interface getting in the way.

The game board can be huge and needs to be scrolled either by swiping with 2 fingers or by swiping
with 1 finger.
There is no clock and no mechanic to set a flag on a mine.
It is very simple and has no in-app purchases or adverts and as such is another
paid app it is at the lowest tier apple will allow apart from free.

I hope you enjoy the game and as ever i am always looking forward to the feedback.

Sales blurb
Our latest iOS game Minesweeper Deluxe
The game just gets harder...
#iOS #Game #a11y #Accessible



Submitted by Chrystal on Friday, November 23, 2018

Ok so I don't get it at all. Could you please explain what the different sounds and all the jargon means. I mean, I'm guessing when it says empty at 1 1 etc, there are no mines there, but beyond that, I'm a bit stuck.

Submitted by John from Woodside Apps on Friday, November 23, 2018

Club AppleVis Member

In reply to by Chrystal

Thank you for supporting the game.

Empty means there are no mines at all in the 8 surrounding squares.
A whoosh sound effect sounds when you have selected a empty square.
All the adjacent squares to the selected square that are empty are revealed.
A square that has a number between 1 and 8 means that there are that number of mines in the surrounding 8 squares.
The idea is to isolate the mines by revealing all the squares that are either empty or have a number of on them leaving the squares that have mines in them.

It is a lot easier to play than to explain once you get it i hope you enjoy the game.

Submitted by Chrystal on Friday, November 23, 2018

In reply to by John from Woodside Apps

Sometimes when I select a hidden square, a bomb sound happens, and it still says hidden. If I tap it again, it'll either make the same noise again, or empty all the squares around it, including previously found ones. What does that mean? Also, i sometimes manage to get a musical sound out of it, which I take to mean I've bumbled through to the next level, but I'm not sure, as the writing always says level 1. On some occasions, it says I've found a bomb, but the message always says something like "You've found a bomb! Next level is 1, it has 3 mines to find in a 7 by 7 grid.".

Submitted by AnonyMouse on Sunday, November 25, 2018

Member of the AppleVis Editorial Team

How does one mark/flag a bomb?

Submitted by Chrystal on Monday, November 26, 2018

unfortunately the game just makes no sense whatsoever to me, so I deleted it. Hopefully others will have more joy with it than I did.

Submitted by Unregistered User (not verified) on Wednesday, November 28, 2018

I'd like to thank you for the post
Well, What I am about to say next is my own personal opinion. Firstly, why is it called minesweeper deluxe? As far as I understand, this is just the normal version of minesweeper. I also really feel that a game like minesweeper should not be paid. I’m not saying it’s bad, but as far as I understand, it hasn’t got any extra features. This is just constructive criticism.
Best regards
<a href="https://appsync.biz/dafont/">Dafont</a&gt; <a href="https://downloader.vip/mapquest//">MapQuest</a&gt; <a href="https://appsync.biz/filehippo/">FileHippo</a&gt;

Submitted by dvdmth on Tuesday, December 4, 2018

Club AppleVis Member

As someone who used to play this game years ago when I had better vision, I have to say that I’m a bit disappointed with the current implementation.

The game mechanics are fine, but the levels are not getting harder as advertised. I’m already past level 60, and if anything they are getting easier, not harder.

The problem is that the number of mines is growing too slowly relative to the size of the board. The first level had 3 mines in a 7 by 7 grid, or about 6% of the total area of the board. Now I’m up to 11 mines in a 22 by 22 grid, which is only about 2% coverage. There’s a huge amount of empty space, the mines are easily found without having to do much logical thinking, and sometimes a level is cleared immediately after starting because there are no spaces left to clear after the initial sweep. For me the 7 by 7 level was harder than what I’m getting now, where the only challenge is searching through all the empty space looking for the one or two spots where I actually have to do something.

Of course, it’s been ages since I last played Minesweeper, but I’m pretty sure there should be more than 11 mines in a grid that has 484 spaces in it. I think, therefore, that the level progression needs to be reworked so that higher levels actually present more of a challenge. I’m not sure what the best approach would be, but the current system doesn’t work, at least through the first 60 levels.

Submitted by John from Woodside Apps on Wednesday, December 5, 2018

Club AppleVis Member

In reply to by dvdmth

Thank you for the comment the level of difficulty is something i struggled with.
It is set low to start with to allow people who have not played the game to get familiar with the game.
I agree it is to slow to get interesting at the moment.

A percentage could be implemented quite easily and will be appearing in version 1.0.5 and above.
The only question is what is the highest percentage that is playable or do i just let people find their own level?

Thank you all for supporting the game and the feedback.

Submitted by charles on Wednesday, December 5, 2018

I got the game yesterday, and have a thought on how to change the difficulty. When the game starts, let's say after you have completed 10 levels to get the idea of the game, you are presented with two fields into which you can enter numbers. The first would be the grid. If you enter 10, it would be a 10 by 10 grid. The second number field would be the number of mines you want to have planted. There would also be a "random" button that gives you a random level of difficulty. I am having fun with this game, and thank you for providing it. Also, I feel that it is priced fairly. Also, thank you Anonymouse, for the podcast.

Submitted by That Blind Canuck on Wednesday, December 5, 2018

For starters, let me just say that I was lucky enough to get a promo code from Anonymouse after listening to this month's AppleVis Unleashed podcast and I am finding myself playing this old classic more and more.

Recently though, I have encountered a small glitch and was hoping that others were also encountering this same glitch.

As suggested by Thomas, when playing, I set the rotor to Vertical Navigation, which makes playing and getting a visual idea of the board a lot easier. When swiping down to Row #2, if I swipe down once again, focus is brought to the top of the window, on the Level #. I don't recall experiencing this in earlier levels. Perhaps this was introduced in the recent update from today?

I'm curious to know if others are also encountering this little glitch.

Either then that, wonderful game. Now one little suggestion, before I forget. When trying to sweep and flag the mines, if you accidentally tap on a mine, not sure if the original game on Windows used to do this, but is it necessary to go down one level?


Submitted by Chrystal on Wednesday, December 5, 2018

In reply to by That Blind Canuck

When you open the game, go into options, which is the first button when the game opens, and turn scrolling off. That'll fix most of that issue.

Submitted by That Blind Canuck on Wednesday, December 5, 2018

Thanks for the tip, but I already had that setting turned off. I think it has something to do with the higher the level you get, the more columns and rows are on screen and that perhaps, visually, those additional columns and rows are hidden, not sure.

I seemed to have fix it for now, by changing the tile size down to 1. A small suggestion to the developper, when opening up the games options, when selecting to change the colour or adjusting the tile size, it would be nice if the game options window doesn't close each time you select an option. I know it's nothing major, but having to go back to the game options each time I adjusted the tile size by 1, was a little annoying.

Either then that, I am definitely loving the game so far. Brings me back to the good old days on Windows 3.1 and how many hours I spent playing Minesweeper, Solitaire and even Taipei.

Submitted by dvdmth on Thursday, December 6, 2018

Club AppleVis Member

I looked up what the difficulty levels are in the Windows version of Minesweeper. They are:

Beginner = 10 mines in a 9 by 9 grid (12% coverage)
Intermediate = 40 mines in a 16 by 16 grid (16% coverage)
Expert = 99 mines in a 30 by 16 grid (21% coverage)

I never liked the expert level, because at that setting there were too many cases where you had to guess to proceed, because there wasn’t enough information to deduce the mine locations logically. I think I played the intermediate level most often, at least when playing the Windows version of the game. There was actually a Mac clone of Minesweeper which I liked better than the Microsoft version, but I don’t remember what it was I preferred about the Mac version.

It would also be nice if I could put an upper limit on the board size. I am finding that VoiceOver acts sluggishly on my iPad Mini 4 when the board is larger than 20 by 20 or so (forget exactly when it started slowing down).

Submitted by dvdmth on Thursday, December 6, 2018

Club AppleVis Member

I should also comment about vertical navigation, since an earlier comment was encountering a glitch with it. The problem is that vertical navigation does not scroll the screen, whereas swiping left and right will scroll the screen if necessary. So, if the element you are focused on is at the bottom, and you swipe down, nothing will happen, or you will end up on an element that’s outside the playing area.

I actually have scrolling turned on in the game settings. In that mode, I can double-tap on any exposed square and have it moved to the center of the screen. So, if I want to move down and the vertical navigation won’t let me, I can just double-tap somewhere to have the screen scroll, then try swiping down again. So far this has always worked for me, but your mileage may vary (I am on an iPad, after all).

Submitted by dvdmth on Thursday, December 6, 2018

Club AppleVis Member

Just got the new version of the app, and the difficulty is much improved now. I had to reset to level 1, because the level I left off at was insane (more than 50% I believe). The lower levels play much more like the game I remember from my childhood.

If you’re wondering about how high the percent coverage of mines should be, perhaps this page can assist:


That shows world records based on the maximum number of mines solved at various board sizes. For the smaller sizes some were able to solve puzzles with more than 50% coverage, but for the larger sizes the maximum percentage drops to around 30% or so. The higher the percentage, the more the game relies on chance and the less you can solve with logic. I remember how much trouble I had at the expert level, with 21% coverage, and I can only imagine how it would be like to play a board even more dense than that, but apparently some people have.

Submitted by Jesse Anderson on Thursday, December 6, 2018

In the earlier update, I was thinking the game was too easy as well, but that has definitely been fixed. I too had to restart the game from Level 1, because Level 46 was pure madness. I was almost always finding a mine in the first couple of moves. I'm back up to level 11 though, and the game is already a lot more challenging. It's also worth the asking price

Submitted by venova on Monday, December 17, 2018

Nice work on this game. Got a gift card for a birthday present today and I got this game because I love games where I actually need to think and concentrate. A detail I really love is that I don't actually have to go back to level one after failing. I have one request and it is for a place where I can see what my highest level is. Think I have reached level seven.

Submitted by venova on Monday, December 17, 2018

You cannot change the difficulty. It gets harder each level.

Submitted by John from Woodside Apps on Tuesday, December 18, 2018

Club AppleVis Member

In reply to by venova

Version 1.1.0 has just been sent to App review and contains a highest level in the menu.
And a belated Happy Birthday.

Submitted by venova on Tuesday, December 25, 2018

What does the scrolling option in the main menu mean?

Submitted by John from Woodside Apps on Wednesday, January 2, 2019

Club AppleVis Member

When scrolling is on the game will move the board so the selected cell is
near the middle of the screen.

Hope this helps