Can't follow links in Messages app

Member of the AppleVis Blog Team
Forum
iOS and iPadOS

Has anyone figured out how to follow a link that is included in a text message? If I double tap the message, it simply reads the message, along with the link. If I rotor to links, flick down to the link, and double-tap, it just reads the link. If I rotor to actions and flick up and down, there is no action to follow the link. I'm stumped! I'm on iOS 15.2.1.

Options

Comments

Submitted by Bruce Harrell on Wednesday, January 26, 2022

Hi Paul,

I'm still using IOS 14, which works fine with the rotor to links, swipe to link, double tap method. It occurs to me, however, that you might want to try the same method, but when you are on the link and before you double tap, first use the rotor again to the edit option and swipe down to select, then double tap it, and then double tap again to execute.

Or,

Instead of doing the above, and instead of simply double tapping when you are on the link, double tap and hold, or if you have deep touch capability, single tap and press hard.

Hope one of these works.

Bruce

Submitted by PaulMartz on Thursday, January 27, 2022

Member of the AppleVis Blog Team

I appreciate the reply, Bruce. I'm not sure why I seem to be the only person having this issue. I'm on an iPhone SE 2020, if that makes a difference.

Neither of your suggestions helped with VoiceOver enabled. So I disabled VoiceOver and went visual - something that won't be an option much longer - and here's what I found. A simple tap on the link did not activate it. I had to hard press the link. A hard press opened a context menu, and one of the options was "follow link".

Unfortunately, I was unable to find a way to open this menu with VoiceOver. A hard press with VoiceOver bringsup areaction menu (heart, thumbs up, etc).

Is there some secret way to do a hard press in VoiceOver that I never learned?

Submitted by Holger Fiallo on Thursday, January 27, 2022

Using current iOS and nothing. Does not work well.

Submitted by Bruce Harrell on Thursday, January 27, 2022

Hi Paul,

Sounds like there's a conflict. See if you can redefined the hard press command (or whatever it's called) in settings>accessibility. I'd give it a try.

good luck,

Bruce

Submitted by PaulMartz on Thursday, January 27, 2022

Member of the AppleVis Blog Team

Thanks, Bruce. I've looked through Settings and found no obvious way to change the behavior, but I'll keep working on it.

I upgraded to 15.3 and found no improvement. This is still a bug. I'd like to see it entered in the AppleVis bug database. It's seems medium-ish. Of course the problem might be that I simply don't know how to do the peek gesture, but it seems to work fine with VoiceOver disabled, so I don't know what I'm doing wrong.

Possible workaround:
1. Rotor to links and flick down to highlight the link.
2. Double-tap and hold until the Reactions menu appears.
3. Find the Copy button and select it. Note that you might not be able to find this with swipe right and swipe left. You might have to drag your finger around. This should probably be reported as a separate bug.
4. Open Safari, go to the address bar, and double-tap and hold to open the context menu.
5. Select Paste And Go from the context menu.

This works, but it's pretty tedious. I remember the early Mac commercials from the 1980s that compared an IBM PC with a stack of binders and manuals to a Mac with a little pamphlet for a user guide. The message was clear: Apple products are easy to use. Anyone besides me yearn for those days?

Submitted by Bruce Harrell on Thursday, January 27, 2022

Thanks Paul.

Perhaps this won't work on IOS 15, but it's a method that's different from what I usually use, so I thought I'd mention it:
1. go to message.
2. rotor to actions, flick to more and double tap.
3. focus on message.
4. rotor to actions, flick to activate and double tap.
5. The link web site or whatever is now open on my screen, but as we know, I still have IOS 14.

Submitted by Yvonnezed on Friday, January 28, 2022

Links in messages are kind of interesting. While trying to test this, I ran into three different types of links, none of which I have to admit I had any trouble opening.

First type, the link and the message seem to be separate. Read the message, flick right, find the link, double tap that and it opens.

Another type was just a link, no message. Again, I just double tapped on the message and it opened the link.

The final one was a youTube video, and in that case "open link" appeared in the actions rotor and I opened it with that.

this is an iPhone 7 on 15.3.

Submitted by Chris Hill on Friday, January 28, 2022

Yes, I've reported it, and those having it should report it as well. I've found the only way around it when it occurs is to copy the message to somewhere else, and do the same for the link if I can't manage to just copy it from the message. If enough people have the problem and report it, maybe it will get to someone's priority list.

Submitted by DK6 on Thursday, February 3, 2022

Hi!

I have the same issue on IOS 15.2.1.

What I do is to first use rotor links and flick up and down until I find the link I want to activate. Then I switch to rotor action and select activate. This will open the link in Safari (at least for me).

HTH
Regards
DK6

Submitted by PaulMartz on Thursday, February 3, 2022

Member of the AppleVis Blog Team

Thanks, but I've already tried rotoring to links, selecting the link, rotoring to actions, and double-tapping. It doesn't work. As I mentioned previously, the only solution that works is to select the link text and paste it into the Safari address bar.

Interestingly, if the text message contains only a link, everything works great. I just double-tap the message and the link opens in Safari. The problem occurs when the message contains both normal text and link text. In this case, I can't follow the link.

Submitted by Clare Page on Thursday, February 3, 2022

Hi! I've noticed, while reading this thread, that several people who have had a problem opening links in the Messages app use an iPhone SE 2020: I have used that iPhone model since just after it was released, but I have never had that problem: I open the message, turn the rotor to Links, swipe down to the link I want, double-tap, and my browser opens as normal. I realise this problem isn't just on this model of iPhone, but I can't help wondering why links open fine for some of us in Messages and not for others.

Submitted by Mabbs92 on Thursday, February 3, 2022

Hi--glad to know I'm not as crazy as I thought (although still a nut haha). I am also having this problem and a friend of mine is as well. Where links used to activate before when moving to them in rotor then double tapping, now nothing happens. What I do is move to it with rotor, then copy to voiceover clipboard (three finger quad tap IIRC). Then I go and paste it into the browser (I have assigned a permanent gesture to paste which makes this less of a PIA). For context, my friend and I are running IOS 15.2 on iPhone 13 Mini.