Changing the dictation language

Forum
iOS & iPadOS
Is there any way to change the dictation language without changing the display language? Currently, when I dictate something in a different language, my phone still thinks I'm talking in English, and it tries to find the closest English words to what I'm saying. I'm running iOS 7.0.6. Thanks.

Options

Comments

Submitted by Aaron C on Saturday, March 15, 2014

Add keyboards for each of the different languages you want to dictate in. Then, when you want to dictate in a particular language, simply switch your keyboard to use that language, and then hit the dictate button (or whatever it's called on that particular keyboard). It will recognize your speech in the chosen language.

Submitted by Aaron C on Saturday, March 15, 2014

Go to settings, general, keyboard, keyboards, add new keyboard. You will find the control to switch keyboards next to the dictate button. Two-finger double-tapping should still work for launching dictation. Luck. Aaron

The control is labeled Next Keyboard, and it appears to the left of the Dictate button, but it only appears if you have added other keyboards besides the default one. However, I couldn't get the two finger double tap to work in some languages, and the Dictate button does not appear in those languages. Maybe you have to set up something in Settings to get dictation to work in these languages? Languages that I've found so far where dictation doesn't work include Arabic, Greek and Hindi.

Submitted by Aaron C on Sunday, March 16, 2014

It's probable that if the dictation button doesn't appear, then it simply means that dictation isn't supported for those languages.