Changing how VO reads punctuation in iOS

Member of the AppleVis Blog Team
iOS and iPadOS

I want voiceover to read more punctuation than it does by default, so I know when there are quotes and things, but I find the way it reads things when set to "all punctuation" virtually unlistenable. Firstly, it doesn't pause at the end of a sentence; it says "period" and then carries on in the same breath, as it were. Secondly, it does pause at commas, but doesn't say the word comma as you'd expect. Having a pause at the commas but no pause at the end of a sentence completely destroys the flow of the text. Third, it reads out all the apostrophes in the middle of words, so "don't" becomes "don apostrophe t", for example. Finally, there are two types of brackets that voiceover calls "left bracket" and "right bracket", leaving no way of distinguishing between the two.

I thought I try using the pronunciation editor to solve these problems. Changing the pronunciation of one of the types of brackets didn't work at all. I finally managed to get it to pause at the ends of sentences in all punctuation mode by changing the word period to period, with a comma after it. I couldn't do anything about the apostrophe issue. I tried things like changing won't to wont, with no apostrophe, and even tried changing the pronunciation of phrases like "won apostrophe t", but neither approach had any effect. Does anyone know of any other ways to get more control over how voiceover reads punctuation in iOS?



Submitted by Justin on Sunday, February 12, 2017

The one thing that annoys me is when reading some things even though you have the punctuation set to none, VO tends to say ellipses. This has been going on ever since iOS 5 as far as I can clearly remember. Thank god the Mac os never says them. Also, just wanted to point out that when using the speak screen feature, put finger on status row and swipe down with two fingers, ellipses are never spoken.

Submitted by Dawn 👩🏻‍🦯 on Monday, February 13, 2017

Her's my pet peeve. I'm irritated with VO. not saying apostrophes! It trows me off, because I don't think I've put it in jhe document. But it reads it when I go to edit the field/document.