Do not disturb with voiceOver

Forum
iOS & iPadOS
I have noticed when I use do not disturb with the latest iOS on iPhone 5, sometimes voiceOver will speak alerts for calls. I can't remember if texts are read, I have times where it works just as I expect it, but sometimes when I really don't want to be disturbed, I get the alerts, but no ringtone. Has anybody else experienced this? I am concerned it will do it in a meeting or some other important event. Fortunately that has not happened, the most inconvenient time was when I was unwell a few weeks ago and I didn't want to get up to answer, so fortunately I didn't have to worry about anyone else hearing the alert messages from VoiceOver.

Options

Comments

Submitted by sockhopsinger on Thursday, August 22, 2013

I have had this happen before as well. However, when it has happened to me, I have had the screen unlocked. Whenever my screen has been locked, I have not had this problem. Was your screen locked when you got the alerts? If not, then it would make sense that it would alert you.

Submitted by Chelsea on Thursday, August 22, 2013

In reply to by sockhopsinger

You're not the only one having this problem. This is a known bug. I have reported it to Apple, and hopefully they will fix it in the next iOS. The best way to get around this is to mute your phone at night.

Submitted by Mike Taylor on Thursday, August 22, 2013

I could be wrong, however my understanding of this feature is that Do Not Disturb only works while your screen is locked, like a previous user wrote. If you are on a call and your screen is unlocked, or if you unlock your screen while Do Not Disturb is switched on, any alert will come through. Hope this helps. Mike

Submitted by KE7ZUM on Thursday, August 22, 2013

In reply to by Mike Taylor

correct. You didn't state if your screen was locked or not. If it it was notit clearly says in the setting under dnd, phone must be locked inorder for it to activate dnd. Hope that somewhat helps. lol!

Submitted by Larry Thacker Jr. on Thursday, August 22, 2013

I've not had any problems with calls or texts, but it seems that some or all apps don't abide by it. I don't know if it was ever designed for them to, but it sure would be nice. Facebook has been quite disturbing on more than one occasion.

Submitted by AnonyMouse on Thursday, August 22, 2013

Member of the AppleVis Editorial Team
Something else to check is your Favorites. If you go in to your Phone app. The first tab at the bottom left corner is the Favorites. Those people you have placed with in this area will be able to call through regardless of the Do Not Disturb is set to ON. This is a feature. You can see how that is set up with in the Apple Settings -> Do Not Disturb. By default your Favorites will bypass the DND. So be sure to make everything is set to the way you want. For awhile I had some alerts leak through but eventually were fixed by those updates. I think. I had problems with Twitter for awhile but it finally stopped at some point when I had my Do Not Disturb to set On. Also, as several have mentioned above. Make sure your Screen is Locked. It will only work when the Screen is Locked. HTH

Submitted by Alana on Thursday, August 22, 2013

In reply to by AnonyMouse

I had my screen locked when I turn it on. I didn't set anyone up as favourites yet. Thanks for the advice though. I hope Apple fixes this in the next iOS release.

Submitted by Raul on Friday, August 23, 2013

I had problems with this mode when 2013 began, as many people around the world, but when 6.1.2 came all was fixed. Now I still have 6.1.2 with jailbreak and DND works fine. I have the calls open even with DND active, but no other alerts appear when the screen is locked.