Help needed with stopping VoiceOver from switching languages

Forum
iOS & iPadOS

Good day, while charging my Iphone 6S the voice over voice changed by itself from SA. English to USA. English. This has happened once before but after restarting the phone it reverted back to my default set voice! I tried to change it from the voice settings but no go! Please give me some advice?
regards

Options

Comments

Submitted by splyt on Tuesday, April 19, 2016

Not obvious but easy.

When you set voiceover up it will choose the speech lang based on the text it is currently reading.

This usually is the iOS language but when trying to read text in another idiom it will change accordingly if it currectly detects that idiom.

To stop this behavior put your rottor in the languages option and swip with your finger downwards or upwards. If your first language is, say, english you will hear two options, one called something like default language english US and another called only english US. Put your rottor in the english US without the default and then yit should not change the language on the fly to comply to the text idiom. The default language option should be set up when you want to give control to the reader reggarding the choice of the current language.

If the english us without the default does not appear on the rottor options you will need to add it first in settings general accessibility voiceover speech. Go add the language and it should appear on the rottor

More Like This