iCloud back-up won't automatically back up

Forum
iOS and iPadOS

Hi all,

A very curious issue: my iPhone hasn't backed up when plugged in and connected to wifi since 30th september this year. I only noticed there was a problem when last Thursday (14th October) I got a notification through from settings saying my iPhone hadn't been backed up to iCloud for two weeks. I think, though I'm not sure, that it's attempting to back up but that it thinks some files were unavailable when attempting the last back-up. That's certainly the message I saw this morning when I checked to see if it had worked. The curious thing is when I choose to back up mannually by pressing the 'back up now' button, all works fine. I've tried what I thought was the most obvious solution, namely turning back-up off and then back on again, but that hasn't worked. it's not a massive issue as I could just train myself to back up mannually every day but I would like to resolve it if I can.

I'm using an SE2020 running IOS14.8 and there are no other iPhone devices backed up to iCloud. By that, I mean I have, for example, removed all defunct iPhones and their related back-ups. I can't remember doing anything to my iPhone on 30th September or 1st October which might have brought this about.

Any thoughts?

Options