iOS 12.1 Won't run shortcut using SIRI

iOS and iPadOS

After updating to iOS 12.1 I started experiencing problems when trying to run shortcuts using SIRI. These shortcuts worked with SIRI before the update.

When I speak the phrase to run the shortcut, my iPhone 6 waits for some time and then SIRI reports:

"Sorry, there was a problem with the app"

The shorttcut runs fine if I perform a single finger double tabp to activate it from within the Shortcuts app using VoiceOver.

Has Anyone else experienced this problem and, if so, is there a fix?





Submitted by Theepan on Thursday, November 1, 2018

I have brought it up with @AppleSupport and suggest you do the same. The more people report the more serious they will take this issue.

Submitted by AnonyMouse on Thursday, November 1, 2018

Member of the AppleVis Editorial Team

Typically, when I receive this error. I found that redoing the Siri phrase does the trick and resolves the problem. I would be curious if this works for the both of you. As I agree this sounds like a bug that seem to be removing the ability to remember the Siri command you place for those shortcuts. As I had shortcuts from the previous version and I've not had this problem. Very odd.

Submitted by peter on Thursday, November 1, 2018

Yes, I tried several things that did not seem to resolve the problem. These included:

1. Rebooting my iPhone 6
2. Re-recording the phrase within the shortcuts app
3. Deleting the shortcut from the Settings / SIRI and Shortcust dialog
4. Re-recording and saving the shortcut in the Shortcuts app after following the previous step.

I wonder how prevalent this issue is? Maybe Apple Accessibility will write back or forward the problem on.


Submitted by Holger Fiallo on Thursday, November 1, 2018

I did a hey siri with my shortcut for weather gods and she responded. I also use power button and ask siri another shortcut for weather gods and she responded. Using iPhone X X and iOS 12.1

Submitted by peter on Thursday, November 1, 2018

I don't have hey SIRI turned on. I am activating SIRI from hitting the Home button.
The problem I am having is with shortcuts I created in the Shortcuts app that used to work before the update.

I can get one shortcut which I created after the update to work when initiated with SIRI, but it takes a long time to react. Typically SIRI will display (but not speak) something like "one second please" and wait about 10-20 seconds before running the (one line) test shortcut.

Something is definitely broken here.

--Peteshorcut to

Submitted by Holger Fiallo on Thursday, November 1, 2018

Noticed that with iOS 12, 1201 and 12.1 she takes 2 second to respond.

Submitted by Morten Tollefsen on Thursday, November 1, 2018

I have not a solution, and as stated earlyer in the thread: this is definitely a bug. I use Norwegian iOS and experience the same thing, and it is really irritating because I have made several really helpful shortcuts with Siri input.

Submitted by mendi on Thursday, November 1, 2018

I have a shortcut that I've tried to run through the double tap in my today screen widget, and it worked flawlessly under iOS12.03, or whatever we were up to. Now, with iOS12.1, a piece of the shortcut runs, but the piece that is supposed to open an app results in me getting a message stating it cannot open the app. This is a shortcut I created in the shortcuts app. So yes, there are definitely issues.

Submitted by peter on Thursday, November 1, 2018

In one of my previous posts I indicated that VO was not giving me any indication of which text was a variable in a text field. Someone suggested that variables are identified in edit fields by adding the word "attachment" when speaking the variable name inside of a text field.

I stand corrected. Although VO does not seem to add the word "attachment" to variable names inside of text fields when one is not editing the field but simply reading it, VO will add the word ""attachment" to the variable name when one is actually in edit mode and navigating by words. I still don't hear the added word "attachment" when just flicking to the edit field and having its contents spoken.

But at least there does seem to be a way of having VO identify variables embedded within text fields.



Submitted by Rocker on Friday, November 2, 2018

Tried to set up the record to clipboard shortcut though I can run it from with them shortcuts the key phrase does not work as Siri does say “there was a problem with the app! Will report to Apple accordingly! Good job guys

Submitted by peter on Friday, November 2, 2018

Well maybe that is good news that it is the app and not the update that is broken. We might see a quicker response from Apple!


Submitted by peter on Wednesday, November 7, 2018

As reported above, initiating shortcuts via voice command was broken with the iOS 12.1 update.

A day or two ago, Apple released an update to the Shortcuts app. The new version is 2.1.1.

With this update to the app, voice commands will now (mostly) work to initiate a shortcut but there is a very long delay.

1. If the Shortcuts app itself is not already running when one tries to initiate a shortcut via voice, it takes 60 seconds or more to start the shortcut on my iPhone 6.

2. If the Shortcuts app itself is already running in the background when one tries to initiate a shortcut via voice, the delay before the shortcut starts running is 12-20 seconds on my iPhone 6.

So, the good news is that, with this update to the Shortcuts app shortcuts can now be run via voice. Unfortunately, there is a long delay before the shortcut starts.

Hope Apple addresses this. I've been in touch with Apple Accessibility and they keep asking me to run more test with and without VoiceOver, with and without WiFi, etc. No fix yet.

What are others experiencing with voice initiated shortcuts they have created?


Submitted by mendi on Thursday, November 8, 2018

I haven't tried voice shortcuts again just yet, but I did notice from the widget that my shortcut that I would run that opens an app once again works. I will try it via Siri tonight, as it is a shortcut I have set to run to get my phone ready for sleep.

Submitted by mendi on Friday, November 9, 2018

I did try the shortcut using Siri, and it did work. As a previous commenter stated though, there was a delay before it ran. This is on an iPhone8.

Submitted by Kelly Hill on Wednesday, November 28, 2018

I am Running the very latest versions of iOS and the Shortcuts app and I still cannot run shortcuts that I have created using Siri. They run just fine from within the Shortcuts app. I haven’t tried the widget as I do not use the today screen. I thought it Could be just voiceover users who are experiencing this problem because when I googled it stuff from Applevis came up first. It doesn’t seem like that would be the case if the problem was Moore widespread. Or maybe cited people just don’t use Shortcuts??? So I tried running my Shortcuts with voiceover off but that didn’t help either.

Submitted by peter on Wednesday, November 28, 2018

With the latest update to iOS 12.1 the problem with not being able to run shortcuts from a SIRI voice command seems to have been mostly fixed.

I use VoiceOver on an iPhone 6. The only issue I see now is that when I try to run a shortcut with SIRI, if the shortcuts app is not already running in the background, it takes some time for my shortcut to run. This seems to be because in order for the shortcut to run, the shortcuts app must be opened.

After I run the first shortcut which opens the shortcut app in order to run, then the next shortcut runs faster, presumably because the shortcuts app is already running.

BTW, since iOS 12.1 there has also been an update to the Shortcuts app. I think my problem was fixed not by the updated version of iOS but by updating to the latest Shortcuts app. So you might try updating the app if you haven't already.