Safari on iOS hangs when using VoiceOver

iOS and iPadOS

When I'm using Safari, and try to read the page with VoiceOver, the browser completely hangs. Even when I turn off VoiceOver, Safari still doesn't respond to any taps or swipes. The only thing that helps then, is to completely shut down Safari (removing it from the app switcher). When I then restart Safari, the app crashes and restarts. After the restart, the app works as expected, until I turn on Safari.

I started having this problem after updating to IOS 11. The 11.0.2 update seemed to make it happen less frequently, but after updating to 11.0.3, it happens every time when I open Safari.

I'll file a bug with Apple, in the hope that they fix this ASAP, but is anyone here having the same problem, and did you find a way around this?

I didn't see this in the list of IOS 11 bugs.



Submitted by Jesse Anderson on Thursday, October 26, 2017

yes, I have had the same crashing bug since upgrading to IOS 11. Oddly I didn't have it happen during the IOS 11 beta, so yeah...

I've had Safari crash more on my iPad Pro 12 inch, but my iPhone 7 Plus has done it a fair few times too.

I am low vision, so when I turn VoiceOver off and go back into Safari, I can see the app responds perfectly fine without VO. I can scroll up and down the page, click links, or pinch to zoom. Starting VoiceOVer again instantly freezes Safari though.

Often, closing Safari from the app switcher doesn't fix the problem. When this happens, I usually hold the Lock button until I get the shut down message, then Hold the Home button to do a quick memory reset. After this, I can usually use Safari for a while before the crash happens again.

I did report this to Apple, but I would also encourage anyone else to report these types of bugs as well, not just posting them here. Hopefully, the more people that submit the feedback, the problem will be more likely to be addressed.

This Safari crashing bug has been the most annoying glitch of IOS 11 for me so far. The odd focus jumping issues being a close second.

Submitted by Johanna on Monday, October 30, 2017

I’m using iPhone 7 and had the same problem since upgrading to IOS 11. Disabling all ”Experimental Features” in Safari settings solved the problem completely for me.

Submitted by Jesse Anderson on Tuesday, October 31, 2017

Hmmm. I didn't even realize those settings existed. The only 2 that are enabled on my phone, both of which I have no idea what they do, are Constant Properties and Viewport Fit. No idea what these even do. If I get another crash, I may try disabling these. thanks for the suggestion. Hopefully IOS 11.1 will fix things too.