Screen Curtain Not Automatically Turning On With VoiceOver

Forum
iOS & iPadOS
My friend and I both have iPhone 4s running iOS 6.1. I typically use my phone with the screen curtain on. When I turn VoiceOver off when the screen curtain has been on, the screen curtain automatically turns off with VoiceOver. When I turn VoiceOver back on with tripple click home, the screen curtain automatically turns on as well, without me needing to perform a three finger tripple tap. However, on my friend's phone, the screen curtain will not automatically turn on with VoiceOver, even though the screen curtain was on when VoiceOver was turned off with tripple click home. Is anyone else having this problem or could anyone help us find the reason for this? Many thanks in advance.

Options

Comments

Submitted by Mike Freeman on Thursday, December 20, 2012

I'm using an iPhone 4 with the latest iOS. Prior to this last update, the Screen Curtain setting (ON or OFF) was preserved over resets, restarts and VoiceOver being disabled and then reenabled. However, I now see the behavior you describe, i.e., with each restart of VoiceOver, if one wants Screen Curtain ON, one must enable it manually with the three-fingered tripple-tap. I don't care which way the behavior works but would appreciate it staying consistent!

Submitted by FruitGeek on Friday, December 21, 2012

I believe Apple made it that way in case a sighted user accidentally gets screen curtain enabled. You can make screen curtain toggle with VoiceOver using iTunes to enable VoiceOver. They published an article about it recently. http://support.apple.com/kb/TS4448

Hi, Sometimes VoiceOver forgets that it's supposed to turn on, so restoring in iTunes fixes it. If you have a backup via iCloud, or iTunes, you should just be able to restore, and all your settings and apps will be how they were before you restored. I've had this a couple of times as well on both my iTuch 4th gen and my 4S.

Submitted by Shane on Friday, December 21, 2012

So is this a bug per-say, or just the way Apple made it? And to fix this, you would have to hook your phone to the pc, then enable VO using iTunes? Would you use universal button to enable VO? Is this right? For me, it doesn't really bother me to have to three finger tripple tap to turn the curtain back on when toggling VO back on, or rebooting the phone and having to turn the curtain back on again.

Submitted by Nicholas Parsons on Tuesday, January 1, 2013

It doesn't seem like a feature to me because the screen curtain comes back on with VoiceOver on my phone but does not on my friend's. And our phones and iOS version are exactly the same. She has tried a restore but it's still exactly the same. If Apple wanted it to work this way, then how did I get mine to work the way it does? And, more importantly, how does she get hers to work the way mine does? It's not that it's a huge problem having to three finger tripple tap when VoiceOver is turned back on, it's just that based on my phone as an example it's not necessary to do so. If it's possible for the screen curtain to come on automatically with VoiceOver, then why isn't her phone doing it and how do we get it to work? Thanks for all your input. It's nice just to know some other people are having this problem.

Submitted by Mike Freeman on Tuesday, January 1, 2013

Nicholas: This is not exactly a bug or feature, but a "quirk". Just hook your iPhone up to your PC and use the "Universal Access" button on iTunes to turn on VoiceOver (yes, even though it's already turned on). You'll find that the Screen Curtain setting is now saved over resets and the iPhone being turned off. The reason a restore may not have worked is that this is a quirk of the operating system, not apps.

It works. Now my screen curtain comes back on automatically, even, both when I turn off VO with tripple-click home or when my phone dies on me lol. Glad to know that this is fixable. I was getting really frustrated for a while there, because it wouldn';t come back on automatically, like it did for me in iOS 4.x, when I first got my phone. I thought it was a bug (or feature), that Apple had put into iOS 5, and I couldn't figure out how to get it to stick. Thanks for the tip, Shersey

Thanks, Mike. I'll try what you suggest. Someone in the comments suggested turning on VoiceOver through iTunes but this didn't make any sense to me without your context as we weren't having any problems getting VoiceOver on. Thanks again for your help.

Submitted by Shersey on Wednesday, January 2, 2013

In reply to by Nicholas Parsons

The issue isn't whether you can turn on VoiceOver, the issue is getting your screen curtain setting to stick. To do this, you either have to turn VoiceOver on using the "Universal Access" button in iTunes (even if VO is on already), or complete the setup assistant with VO on. I know, it's weird, but that's the way you have to do it. I just did it through iTunes, and the setting has stuck. Hope this helps, Shersey

Submitted by Signaltonoise on Thursday, January 3, 2013

I was having the same problem too. So, I plugged my iPhone into my Mac computer and went to universal access and clicked on voiceover and the screen curtain is now active when I turn voiceover on with triple click home. Note: I had to turn VO on my iPhone first then turn on the screen curtain to make this work again.

Submitted by Andira Pramatyasari on Thursday, January 3, 2013

dear all, thanks for your suggestions. Actually, Nicholas posted this question to helped me fix my problem about screen curtain. I connected my iPhone into my Mac then turning on the VoiceOver using universal access button on the iTunes. Now screen curtain stay enabled after I toggling VoiceOver.