Voice Dream not able to download books from Google Drive.

iOS & iPadOS

Hello to all,

Last evening I tried downloading my first Bookshare.org book onto my IPhone 6+, with iOS 8.3, running Voice Dream and have run into what may be a minor issue.

After opening Voice Dream on my IPhone and logging into my Google Drive account from within the app, I located the book I wanted to read. When double tapping on the book, it came up with a message saying that Download Is in Progress. Well, I allowed this to continue but after waiting 15-minutes for it to download a 331-KB file, I canceled this download. I retried this action just a short while ago and got the same result.

Is there something simple I am not doing rite which is not letting me read my books? Any ideas or info about this will be appreciated.

Thank you in advance,




Submitted by KE7ZUM on Sunday, April 19, 2015

Can you go the other way from GDrive to voice dream reader? This might br a temprary work around until the autor can fix the issue

Submitted by John Gurd on Monday, April 20, 2015

I just downloaded a text book and then a zipped audio book from Dropbox using the latest update of Voice Dream. Don't know about Google but it's working fine with Dropbox.

Submitted by Mark on Monday, April 20, 2015

Well. As I said. It appears to be a simple issue which I appear to have solved. When downloading Bookshare.org books. I did not understand that I could download them directly from my bookshare.org account into Voice Dream from within the Add option. I was under the impression that I had to download them to my main PC, transfer them to my Google Drive account and access that account with my Voice Dream app on my IPhone. As I usually do, I was making it harder than it really is.

Thank you to those who responded with their questions and information. I am sorry for making this a harder issue than it really is.


Submitted by Ascend on Friday, June 16, 2017

I had the same problem. Perhaps you had a recent new iphone and restored from your back up. And then it did not work. Now you can do the following:

1. Go to you App store on your iPhone and click Updates for Voice Dream and updated it.

2. If that does not work then deleted voice dream and then reinstalled it and then see if there are any updates for Voice Dream. This is what worked for me.