iPhone 7 won't ring when a call comes in

Hi All,

Recently when I receive a call on my iPhone 7 the call goes directly to my voicemail box without ringing, and btw I don't have my voicemail set up.

I've just started fooling with the call and text features of the phone and my mom is my only contact.

I recently tried to change the ring tone and text tone and I believe that that's when this all started because before that I'd occasionally receive calls, presumably from robo calls, and the phone would ring then although I wouldn't answer. I first changed the tones just in contacts under my mom's contact because I didn't realize at the time that I could also change it under settings. I went into settings late last week though and found that I could change tones there as well, so I changed them there and then went under my mom's contact and changed the same tones I had set in settings. I think that's actually when the phone stopped ringing, then somebody told me to turn the phone off and back on so I did that and the phone did start working normally for a day or 2 after that, but my mom tried to call me over the weekend and again the call went straight to voicemail instead of the phone ringing on my end. Btw I'm receiving texts with no problems.

Oh and I just checked and my ring tone in settings is set to seaside and the tone under my mom's name in contact is set to I think open, so that might be the problem but I thought different tones can be set for different people so maybe not.

Sorry for this note being so long but I needed to write all I've done and tried, does anybody have any ideas what might be wrong and why my phone isn't ringing?

Forum: 

#1 Do not disturb?

It sounds like you might have Do Not Disturb turned on. You might want to make sure it's off and that there's no schedule to enable it.

#2 Hi,

Hi,
There are times where I've seen this happen. Sometimes callers will go straight to voicemail without the iPhone ringing. I've seen this on every iPhone i've had since the 4S. There are two things you can do. Check the do not disturb feature under settings. The second is reboot the phone with the lock and home buttons held down till the phone either goes dark or stops speaking then restart the device. This fixes the issue.

#3 do not disturb

Schedule was on for do not disturb so I turned that off. I've always used do not disturb though so my phone stays quiet between 11 pm and 7 in the morning and the phone would ring except between those times, is there a different way to do that in the latest IOS?

#4 rebooting

Hi,

So it's the home and power button that I hold down to reboot? I thought somebody told me that to reboot an iPhone 7 I'd use one of the volume buttons and I think the power button, but I don't remember which volume button it was, the down button I think.

#5 Hi,

Hi,
Yes you use the one of the volume buttons to reboot the iPhone 7.
My bad, I'm used to the older phone, and don't currently have one of the newer iPhone 7 models.

#6 Rebooting iPhone 7

Hi

Like others have said, it sounds like you either have do not disturb enabled, which you have checked, or you need to do a hard reboot of the phone. On an iPhone 7, because the home button technically isn't a physical button, you need to press and hold the power button on the side of the phone, along with the volume down button, for about 10 seconds. On an iPhone 6S or under, this is done by holding the power and home button which is where the confusion comes from, but this will not work on the iPhone 7. If this doesn't work, I'd suggest contacting your carrier as this could be a SIM card issue, or some other problem at their end.

#7 You could

Hi Troy you could manually turn do not disturb on and off if the scheduled one is not working properly. That's the only other option that I can think of.

#8 vibrating?

Hi there.

Im probably grasping at straws here, but it's something I'd check. Is your phone vibrating when someone calls? I'd check that, as it may have been toggled on accidentally. Hope this helps. What a weird cunundrum.

#9 do not disturb seems to have been the problem

I hope that everybody who helped me on this topic is receiving a copy of this.

I turned off the do not disturb schedule yesterday, and I also rebooted the phone and at least for now the phone is ringing again when I receive a call. I don't know why I can't use do not disturb anymore unless it's a bug in IOS 10 though, I even added my mom's contact to my favorites since she's the only one I receive calls from and the phone still wouldn't ring with do not disturb on, even during the day when do not disturb should've been off.

#10 There's a new setting in contacts

I think there's a new setting in contacts that effects the pass-through of calls when Do Not Disturb is enabled. I'm not in a position to look up the exact option, but that might have been toggled, although having the contact in Favorites should still work as far as I know. It does work for me.

Actually, I suspect it's restarting your phone that fixed the problem, but I really don't know that for sure.

#11 I phone 7 won't ring after turning do not disturb off and reboo

Just got anew iPhone 7 and did not have do not disturb on and it did not ring. It only vibrates. I turned vibrate to none and phone calls went straight to voicemail. I rebooted holding down the power and volume down buttons hoping that would take care of it. It did not. Any other suggestions. Maybe just get a different phone?

#12 Sounds like a stupid

Sounds like a stupid question, but it the mute switch in the up position, where the phone will say un-muted by VoiceOver?