Revisitting flash player issue

macOS and Mac Apps

Hi all. I tried to ask this earlier, however I only got the unhelpful, was I sure I had uninstalled and reinstalled the player? type of comment. Little did the person who failed to respond to me read, yes, in fact, I did do that. Anyway I discovered if i go onto my guest account, flash content plays fine, on but on the admin account there's nothing. This is free, so it's not like you need to sign in or up or anything. If anyone wants to help fix this, I would very much like it. as call this trivial, but I found out just how speciffic I had my voice over set, when i went into Guest andit helpfully said, "You are on a button, to push this, please use control, option," Meanwhile, I threw nasty words at it, and said, i know!!! Btw, is it at all possible to have NVDA and voice over prefferences on the same thumb drive? Was thinkinf of having NVDA on the root and not sure how i'd acces Mac stuff. Thanks for any help. P.s. youtube is unaffected and so is the new site I visit for the videos and clips of that nature.



Submitted by Nicolai Svendsen on Thursday, May 7, 2015


Being told that you need to reinstall Flash player is inadequate, I agree, especially since it worked on another account.

Try the following:
<li>When in Safari, press CMD-comma to go into Preferences</li>
<li>Interact with the toolbar, then move right to the Security button</li>
<li>Press VO-Space to activate it, then stop interacting with the toolbar</li>
<li>Move right with VO-right arrow several times until you get to the "Allow Plugins" checkbox and make sure it is checked.</li>
I'd say check in ~/library/internet plugins for the plugin as well and make sure nothing interferes with Flash, but that step is no longer relevant. Also make sure in Safari Extensions in the toolbar that you do not have any possible extensions installed which may interfere.

I hope this helps. If not, do reply back! This is what first came to mind. Also try to repair disk permissions as well just in case. That tends to iron out weird stuff as well if changing settings does not.

Submitted by Siobhan on Thursday, May 7, 2015

Hello. Thank you for having a brain. i admit I saw one new, oh no. Anyway I have looked at the plug ins checkbox and it is checked also set it to always allow in the hopes that would work. I only qmee an extension that pays you for clicking on adds I'd say 10 percent of the time as I search, camelizer, a price compareson tool, romola the capcha one that i'll get rid of since i don't use it, and that's it I think. I'll check again. Thank you so much. if this reply is weird, I'm not awake yet. How do i repair disk permissions on a macintosh hd? I don't need a hassel of losing data. Btw, you know i'd blame you if I did right? :P just kidding. Thanks so much again.

Submitted by Nicolai Svendsen on Thursday, May 7, 2015

I've already had one pot of coffee, probably will have more!

Try turning off extensions in Safari briefly, then try using the site which requires Flash again where you could not get it to work. That is one way of seeing whether it may be an issue with extensions.

To repair disk permissions, do the following:
<li>When in the Finder, press CMD-Shift-U to go straight to Utilities</li>
<li>Arrow down to Disk Utility, then press CMD-O</li>
<li>Arrow down to Macintosh HD, then VO-right to ensure the "First Aid" tab is selected</li>
<li>Now, VO-right again to the "Repair Disk Permissions" button and VO-Space to activate it</li>
<li>Then you wait. A while.</li>
This might help you. Afterwards, go ahead and try again. While you are in there, you may as well go ahead and Verify the disk as well.

Hope you have luck with this.