Safari Busy in Lion

Forum
macOS & Mac Apps
These Safari Busy messages annoy me. They seem to happen when reloading a page. For example, go to http://startpage.com and enter a query. Then reload the page a few times and it'll lock up and you'll have to use Command-w to close the window. Apple just released the 10.6.1 update, I really hope it helps, though I don't think it does. I still love my Macs! I just figured I'd get the ball rolling with a post about something current.

Options

Comments

Submitted by frank perry on Wednesday, August 17, 2011

Hello. I seriously think this is an actual bug with accessibility. You see, the problem is every time you start, restart, close down or shut down an application, in this case, safari, apple lion seems to assume you want to resume all of the windows in the application, again, in this case, safari. There is a work around, it's a bit of a problem, but this is the only way I've found around this issue. Insure everything is closed and the only thing you hear or see is the desktop on your apple mac. Now select the apple menu with v o with the letter M and select restart. Take a close inspection of the dialogue box, because a check box has been added to the restart dialogue box. By default, for some silly reason, best known to apple, this box is always checked, and, I've found no way of unchecking this box in system preferences, in other words, I have to insure this box is unchecked before restarting the apple mac, otherwise, like you said, you get these really annoying busy messages with some applications, in this case, safari. So using your cursor keys, locate the check box, press v o with the space bar key to uncheck the box, then select the restart button by pressing v o with space bar on the restart button. Wait until the apple mac restarts, then, select safari, then you should have no further issues. Note. I seriously recommend if any application, in this case, safari, gets busy, and, you get no response, you restart the apple mac using the above steps, remember, if you forget to uncheck this silly check box, safari will resume all previous windows, meaning, you'll get all of those annoying busy messages again.

Attention lion users. 10.7.3 is now available. A huge voice over issue may have been permanently fixed. I stress, no promises here, so feedback is appreciated here please. I stress I am partially blind and I rarely use voice over unless I want to test something with voice over. In this case I wanted to test the new version of lion o s. The pitch use to change sometimes it would go lower for a time and sometimes it would go higher for a time even though the pitch had already been set. Well, the good news is that this doesn't seem to be happening any more. Ok back to safari. I suggest resetting the whole of safari every week at least once a week. Also in the history section in preferences, only allow safari to keep a history of your links you visit for a day. It's also a good idea to check your network preferences every now and then.

Submitted by Felix on Sunday, June 17, 2012

This problem still occurs in Mac OS 10.74 and Safari 5.17. Especially when navigating via headings on big webpages such as Facebook newsfeed Hope they'll rectify this issue in Mountain Lion which is coming soon...

Submitted by Daniel on Saturday, July 7, 2012

Hi, you could also just as a suggestion turn off the resume feature that's current in this OS. Go to system Preps general and uncheck the box that says "restore windows when quitting and reopening apps?" Also in addition due to a Mac OSX update of lion V7.3 or 4, I can't remember which the checkbox that has already been mentioned when you shut down your mac can now be changed and it won't default back to always being checked. I'm not shire if that's been mentioned already but for me if I do the above I experience less busy issues with Apple's Browser.