Strange issues with VoiceOver

macOS & Mac Apps
When I enter a text box and fill it in, and leave that field and go to the next text field, the keyboard cursor doesn't track with the VoiceOver cursor. In other words, I typed in the subject of this particular topic, went to the message field and attempted to type, but even though VO said I was in the correct text field, the keyboard cursor was still in the subject edit box. As you can imagine, it is extremely difficult to type in passwords. Also, before I type in text, I have to press VO-space. Is this normal behavior? The Apple techs have tried to help, but they don't really have enough training in VoiceOver. I got my Mac Mini May 9, and David's Mac Basics Podcasts have been extremely helpful. Any help you guys can give will be appreciated and will possibly lengthen my life. It will certainly lower my frustration levels.



Submitted by sockhopsinger on Friday, May 17, 2013

When you are on your first text field, when you are ready to go to the next one, use the Tab key to get to it. That's what I do and don't have any issues. Otherwise, when I want to enter text into a field, I move my cursor to the field, and then I interact with the edit field with VO plus shift plus down arrow, then do the same with the up arrow when done. Hope this helps.

Submitted by chris R on Friday, May 17, 2013

In reply to by sockhopsinger

Hi. Have you checked that cursor tracking is fully enabled? For example is the voice-over cursor set to track the keyboard curser ETC? This could be causing a problem. To do this go to: voice over utility and select navigation. You will see the options there. A temporary way of turning cursor tracking on or off is to use VO-shift-F3. Hope this helps. I have never heard of this problem before except in the case of partially accessible applications when it is the application's fault not voice-over. Chris :-)

Submitted by Sandy on Friday, May 17, 2013

In reply to by sockhopsinger

I just tried your suggestion, and, Hallelujah! it works... for right now, anyway! I'll let you guys know if this permanently fixes the problem. Thanks!

Submitted by KE7ZUM on Saturday, May 18, 2013

go on to safari prefs then to advanced and check the box that says Press Tab to highlight each item on a webpage. You can then press option tab to move from form field to form field. Now go to the vo utilities and under navigation, *cmd 4 on the number row) tab until you hear automatically interact with items when you press tab. If that is checked tha'ts good.if not, check it. Take care.