MBraille behaving strangely

I have had a strange issue with MBraille on my iPhone 5s lately. When I try to write, VO says nothing, and I only get the clicks telling me I'm writing. Today, when I tried to use the "clear text" swipe, VO said, "Clear test can't be used in Direct Touch mode".
This is strange, because I have typing set to Touch typing in VO settings. So, I was wondering if anyone knows how to get MBrille to behave like it should, again?
Hope somebody can help, because it's difficult to type without hearing what I'm writing. Thanks in advance!



RE: MBraille behaving strangely


I suppose you've activated the MBraille third party keyboard by mistake. Here is how to go back to the "normal" Apple keyboard:

  1. Activate a text field and wait for the MBraille keyboard to show up.
  2. Swipe towards the home button with three fingers.
  3. Now the keyboard has changed to the next, for example the IOS default keyboard.

MBraille gets the settings you've changed inside the app itself, so if you want to hear letters, you have to go to mbraille, settings and turn on say characters while I type. Note: This needs to be changed by opening the MBraille app, not anything related to the settings app on your device.

If all of the above sounds completely wrong to you. please let me know, and I'll try to find another way around the issue you're descriping.

Best regards Thomas

MBraille and Direct Touch

Are you actually getting the clicks that are the character entry clicks, or are you getting the clicks that you get when you touch an item on the screen with VO? Those clicks are slightly louder than the character entry clicks. Try accessing the rotor while in the MBraille keyboard and looking for an option called direct touch. It's not the typing mode, it's another option entirely in the rotor. This is the option that allows apps to bypass normal VO gestures, which is required for MBraille gestures to work properly, including text entry.

Rotor in MBraille

@Froglet But, how do I use the rotor while I'm in MBraille mode? When I try to rotate my fingers, I only get MBraille commands. VO says, Undo or something else corresponding to the gesture I make. I know about direct touch, but I don't know how to get to it while in MBraille.

Re: Rotor in mbraille

Hi @Oystein

No, you can not use the rotor when MBraille keyboard (refered to as MBraille kb) is active. How did it work previously before you found these issues? Does it work to change keyboard as I descriped earlier? Best regards Thomas

What has happened

Club AppleVis Member

What you did was turn on "direct input" in your MBraille. What you need to do is pull up your MBraille keyboard in an application. Hold down dot 6 and swipe right with one finger. You should receive a message saying "direct input off" or something like that. See if that works.

Case closed!

Thanks! That worked exactly as advertised. MBraille is back to normal, now.
This is what's great about sites like this.
Thanks to you Sockhopsinger, and thanks to Applevis for being such an awesome place!


Glad it helped

Club AppleVis Member

Freaked me out too the first time it happened to me. Glad it helped you.

RE: Case closed

Nice, now I see why it didn't make sense to me in the first place.
What I thought you were talking about was the direct touch typing mode in IOS itself, and not the direct input in MBraille.
Since that is not accessible for my language at the moment I was a little unsure about what was going on, but it makes perfectly sense now.
Glad you got it fixed. :)

Best regards Thomas