Problem with iPhone Internet Connectivity

Hi all,

I have a really strange problem with my internet connnectivity. It has been happening for fiew months now. I cann't find any pattern or specific conditions that cause it. No specific dates, days, time or actions on my behalf. It runs from fiew hours to about two days.
Here it is. Usually I have WiFi and 3G on. If the phone uses WiFi, it shows the network name and strenght. If on 3G, it shows it on the status bar. Something happens and I see 3g and the WiFi network name without its strenght side-by-side. I don't have WiFi Assist on.
And the strange thing is that I receive notifications from Messanger and Skype, I have Siri working, But I cann't check for email or open any web site. If I ask Siri something, she answers me, opens apps, calls contacts, tells me what she finds on the web. But if I try to open it from its window or search from Safari, I get "your iPhone is not connected to the internet" message.

It is really, really annoying. I have cleared the app switcher, rebooted the phone, made the hard reset with home and power buttons, reset my network settings, reset all settings, changed the DNS server, but none of these helped. The only thing I haven't tried is to reset as a new device, but setting it all to my liking takes me more than a day, and I don't have such free time.

I use iPhone SE 64GB, iOS 11.0.1. The problem appeared in iOS 10.3.2 so I don't think it is OS version specific.

Anyone with such problem or good advice?

Thanks,
Negoslav

Forum: 

#1 Check your wifi router

I've experienced something like you describe when my router loses connection to the Internet. Basically, the wifi network is still up and running, but Internet is lost. If you have a separate router and modem, you might need to restart both of them. Hopefully this will help.

#2 I missed something

Jeff, thank you for the reply.

I rebooted the router. It is working well. Both my laptops are able to download files, watch video or load web sites. Even if I turn off WiFi on iPhone and leave it only on 3G, there is no internet. It shows 3g connectivity but I can do nothing with it. When I swipe right from 3G icon on the status bar, I hear "Network connection in progress". That usually means that there is no useful connection. If there is, that messages is not heard.

#3 Sorry, it was just a thought

It's obvious your problem is different from the one I had experienced. Sorry, I haven't any other ideas or suggestions.

#4 No problem

No problem. At the end, you are the only one who replied. Thank you.

This morning I reset the network settings again on the work network, and I don’t know what’s the risen, but it’s OK now. I am dictating this comment from the iPhone. We will see when will be the next time, hope it will never happen again.

#5 Could be...

Hello,

Does this only happen at a specific location or does it occur everywhere. Does it only happen when connected to both wifi and celluar? Does this occur if you are only connected to cellular?

I would suggest a reset of your network settings but you’ve already done that. When you went to IOS 11, was it an upgrade or a fresh install? If you did an upgrade, the problem you had in IOS 10 may have carried into IOS 11. In this case, the fix would be to restore to factory default and setup your device as new. If you restore from backup, you might also end up restoring the problem.

HTH and good luck.