Removing the default Siri voice for your language that voiceover uses, completely legal.

there is a bug that is in IOS nine that prevents you from deleting the default siri voice that voiceover uses. I have found a work around, and while it's not as straight forward as it really needs to be, here it is.
1, go to settings, general, language and region and change your default region to something else.
2, once you do that, go in to settings, general, accessibility, voiceover, and speech. Find the default Siri voice and swipe up to delete. Double tap once voiceover says delete. there you go, done, it should be deleted from your device. After it is deleted, go back to language and region, and change your region back to yours. In my case, United States. And the default Siri voice that voiceover uses will be off your device. Keep in mind though, the default Siri voice that Siri uses will still be there. Hope this helps somebody.

Forum: 

#1 I just swipe up and delete

I just swipe up and delete with out changing the region. Hav eyou emailed accessibility@apple.com with the bug report? If not, do that.

#2 Not the only one

I had to do the same thing. I bugged it through their bug reporter, so we'll see who answers.

However, it's apparent, I think, why it complains about it when you attempt to delete. If you switch back to the enhanced voice after deleting, it will use the current Siri voice used by Siri itself, and that is true if you have the enhanced one already. For instance, I can delete the American Siri enhanced Male voice, then double tap it again to select it after switching to Alex. I instantly hear the enhanced voice speaking to me instead of the default one VoiceOVer should be using because Siri already downloaded it, even though VOiceOVer is downloading it too. It's apparent that it thinks you want to delete the Siri voice itself and doesn't want you to, mainly because you're using that particular region. VoiceOver doesn't care. If you go into Settings>Accessibility>Speech without VoiceOVer on and delete them, the same thing happens. IF it used the same voice across the board, this alert makes perfect sense, however, it doesn't.

That's the part that seems more like a bug, as opposed to being unable to delete them, unless Apple doesn't feel like conserving space. If the intent is that you need to have the same voice twice, the alert doesn't make sense, but I doubt it.

Of course, these are observations, but I think it's common sense. The alert gives you a good clue as to how to delete them.

#3 A Helpful Workaround

Member of the AppleVis Editorial Team

I can confirm that this workaround is, in fact, necessary. If one has a Siri voice downloaded, using the Actions item in the Rotor to delete the voice does not work. While you can activate the "Delete" item, an error message is displayed indicating that the voice cannot be deleted.

As counter-intuitive as this sounds, I suspect the reason you can't delete the Siri voice is that it is the exact same voice as Siri actually uses. If I'm right, even though VoiceOver thinks it's downloading the file again (or again and again, in the case of the US English male voice), it isn't actually so and has only one copy of the voice on the system. I've been able to activate the Male US English voice and have VoiceOver start using it instantly, even when it's reporting, "Downloaded X of 145 megabytes..."

#4 Compare your space

Hi!

That's not the case on my phone. It actually does download it on my end. Checking space comparing to pre and post-download, I see an increased usage in storage, which is why I made my point earlier about what the bug actually might be. That doesn't mean everyone is getting that, since things like these sometimes differ.

Edit: As an example, deleting three voices gave me about 600 MB of space, despite that Siri was still using them afterwards. Also, downloading and removing them shows this, which backs up the point I'm making. I thought about doing this after my original comment, but hadn't considered it by the time I replied again.

Oct 26 14:54:11 Nicolai-Svendsens-iPhone vot[1052] : Resetting MacinTalk voices

Oct 26 14:54:11 Nicolai-Svendsens-iPhone vot[1052] : Building MacinTalk voice for asset: file:///private/var/mobile/Library/Assets/com_apple_MobileAsset_MacinTalkVoiceAssets/db2bf75d6d3dbf8d4825a3ea16b1a879ac31466b.asset/AssetData/

then a ton of errors and inability to establish connections after downloading and when deleting, although it's clear both voices are still present. I'm not going to go as far as to change my Siri language when it's pretty certain. Checking space should show it easily enough without checking the logs, since you get a ton of events whenever you just look at it funny. If you're not looking for something like the VOT process, you probably have to sift through thousands of events.

#5 Good point. Why not bug that

Good point. Why not bug that in the feedback utility or by emailing the usual email address?

#6 Premium default Voices

The storage problem is nothing uncommon for iOS users; and now I'm using iOS 10, I've noticed "remaining storage" oscilating between 13 gB and 17 gB, without any transparent reason set out in "Local and iCloud storage" (in Settings > General).
So I took a little tour of the Premium voices in the VoiceOver settings and I noticed I had all the default Premium voices installed (including Arabic, Chinese, Danish, Dutch, Finish, Greek, Hungarian, Hindi, Indonesian, Japanese, Swedish, Thai, Turkish, ....) although I only have 4 languages (French, German, English and Spanish) set on my rotor...
Logically, I removed them, which freed about 4GB of storage. But as I plugged my phone back to charge (and being logged in to my home WiFi), these voices were downloaded again.
Is there any way to disable that?
Or else, if you have the same issue, I would suggest mailing the Apple accessibility team about the bug.