The story and release of Knight Commander.

App Developer

Hello Apple Vis forum
Knight Commander has just been approved for the App Store.
It has been a real struggle to get it their as I seem to have broken almost
all of the guidelines that are set out for developers to follow.

The game is not as far forward as i would like as i have
been busy for the last 2 weeks to get it approved.

As with most of my apps and games they get a whole lot better
when released and people support them.

Thank you to all the people who joined in on the beta testing and gave
good feedback.
Hopefully i now have a core of people who will test future apps.

As for promo codes I have decided who will get one so please do not ask.

As ever all feedback is very welcome.

This is the link


Awesome game

I bought it just now and love it. I haven¨'t come very far hyet because I got it about an hour ago or something but I was a beta tester of this game and have loved it ever since.
The tutorial is very helpful.

Unable to equip tribe members with weapons

I've tried everything. Tapping and holding, tripple tapping etc but no joy. What's the procedure for giving a tribe member a created weapon?It's a very interesting mechanic though and makes a change from 'other games. I'm enjoying it and want to see where this one goes.

Does this have replay value?

Does this have replay value?

Or is it like most role playing games that get put aside once you're done with it.

wow nice!

congrats! , I am a tester too, sorry for being a little bit inactive on reporting, all because the game runs smoothly on my phone, no crash or what so ever. thanks for giving me chance to test the game, John! :)
in the end I recommend this game to everyone, specially if you love Resource management like castaway and such, this game is perfect for you!.
@3: double tap and hold should work.

I fear I will sound stupid...

Okay, still loving the game. I have one strange problem and that is that if I click on a person, and want to go back from the tasks screen, I cannot because I cannot find a back button.
Sorry if I am sounding stupid.

I have already emailed John

I have already emailed John to report this to him.
also I have found my tribe can be very lazy as when they have low health and little time to do work they then stop obeying me and I can't get them to do anything. I have also reported other minor issues to John as well, he is probably fed up with my emails, but at the moment I have several people who are on strike and I can't get them working again. Once they go on strike you will find you get both time and energy warnings then you can't get them to sleep or eat, guess they must have a death wish haha.

lol and another thing

I have problems when trying to give a weapon to a person.
Rofl, they are on strike? Didn't know they could. hahaQ

I can confirm I can't get

I can confirm I can't get people to take weapons either, I guess maybe they are just pacifists lol, I found that when I was attacked this screen is confusing and needs work doing on it plus the app got very sluggish and my phone got warm before I had to quit it entirely.
Maybe I need to be nicer to my workers for the moment before slave master john whips them back into shape haha.


Okay, I am trying to make planks and the character has full energy, as high as I can get it, but it still says energy warning and I cannot even do it. Help?

sounds like you have

sounds like you have rebellious workers, and like your in the same situation as me, I ended up scrapping my game and restarting, though I am sure John will sort this out soon, he said he already took on board a few things I suggested.


Okay, found it in the shop. I was being stupid.

I recommend this game to everyone

I must be really lucky because the game always run smoothly on my iPhone. I was a beta tester and I recommend this game to everyone.
This is an excellent game. Thank you, John, for such a great job.

customizing people

This is not very important but I cannot find this feature in the actual release. Help?

This has been fixed in the

App Developer

This has been fixed in the next update
The intended way of equipping weapons is this
create a weapon
long press on a person
select a weapon slot
select a weapon

The next update is due to be submitted today Fri 10 Aug
so it should be available sometime over the weekend

Thank you for the feedback and apologies for the trouble.

Currently there is no way to

App Developer

Currently there is no way to return from the task screen without assigning a task.
This has been added to the to do list.

A round up of issues so far.

App Developer

A few pointers

The personalize your people is at the bottom of the shop.
people can only be idle,busy or in hospital
Although on strike does appeal.*smile
the weapon and war is very much not finished yet.
The state where no one can do anything is being looked into and will be fixed.
As for replay value there is no set story you decide what you want to build and how you want to fight.

As mentioned somewhere above the next update is today Fri 10 and should be
on the app store over the weekend.
Thank you all for the support and feedback.

A few uestions

I only got this game last night, and still trying to figure it out, since I can't find any pointers in the game itself for this I thought I'd ask here. How do you make planks of wood? As I know how to get wood but make planks I'm not sure, and how do I make meat too as I need that?

planks you need the saw mill,

planks you need the saw mill, if you long press on a building it tells you what it is for and how to build it, like the tutorial showed you with the shop.

Love the game, but?


I am enjoying the game after someone reported it over on

The problem is I seem to be running into similar problems as people mentioned here.
I've tried doing a tap and hold on the people, but nothing is happening, so no way to equip weapons.

Similarly, two of my people now are stuck without enough time to sleep or eat or enough energy to do anything else. It seems a bit silly that there is absolutely no way to get them out of this situation (I tried buying more time in the shop but that didn't work).

I really hope these matters are fixed in the next update.

I also ran into a fight, or rather three fights in a row, or at least a screen that said "this means war" and lots of clashing and sounds of ""your losing" though whether this was because I was trying to kick one of those unworkable workers into doing something I don't know (maybe the people are revolutionaries).

I really hope these things will be fixed in the update, since its fantastic to see a complex single player stratogy game that is accessible, and not all about minimaxing faster than other players.

Keep up the good work, i'll be looking forward to seeing where this one goes, plus anyone who fancies discussing the game over on is welcome.

I'm not sure if this is a bug

I'm not sure if this is a bug or simply not implemented yet.

I'd like to sell some of my tools because I may have made more than I could possibly need at the moment.

They're not showing up in my inventory, stuff like pillows, stone knife, shoes, fishing rod, ETC.

Chopping trees also doesn't appear to do anything, even though it makes the sound.

Finding bones in meat also doesn't appear to work, unless I'm doing something wrong for that one.

Oh and I think fish and chips is listed twice in the food section.

I can't think of anything else at the moment that hasn't already been mensioned.

For the most part, the game is playable, of course there are bound to be a few little glitches in early releases, other games have certainly had more bugs at release, and they costed more.

Keep up the good work.


How does the quest work? How many are they?

Same problem here

Sometimes, when I make an item, for example a stone knife, it shows how mabny they are. However, when I go to the inventory screen, they are all gone and if I go back to tools I don't see them anymore.
Another thing, wich may be a bug or feature, is that when selecting a weapon slot and there are no weapons, I tap the slot and am back on the people screen.
The later is not very important however.

Unable to create the rubber

I am enjoying Knight Commander these days but, am facing a problem.
I have all materials to create the rubber but, am unable to create it.
Does anyone have same issue?

Now this is just silly, you

Now this is just silly, you can't use the water from the well to make clay and whatever else you use water for.

You can sell it certainly, but one would think water is water, no matter where it comes from.

If the water from the well is meant for other uses, then perhaps it should be mensioned in the task help or something.

Now I'm wondering if it's worth making that stone mine if the stones from there are just going to be useless.

I'll probably just make what I can and sell for gold, until all these bugs get squashed.

Hello All and thank you for

App Developer

Hello All and thank you for playing the game.
Some answers so far
The state when all your people cannot work is due to you working them to hard
and not getting food in stock.
You can solve this by using the feed all option in the shop.
You can also send all your people to sleep by Singing a lullaby
Both options cost gold.
Rubber is a bug and has two definitions.
Tools cannot be sold but will be soon
To make clay you need buckets of water and stone
A bucket of water is made up of 1 water and 1 wood.
The war screen is still a work in progress
There are some duplicate items these will be romved.

A in game FAQ and manual is going to be added soon.

Many Thanks for the feedback and support so far.

Bought the game two days ago

Bought the game two days ago and am really enjoying it.
Several things:
1: I can't seem to make rubber. I got the tree, the bowl and the knife, but still it says no material.

2: I been playing two days now and have not seen any battle?

3: I noticed when my warehouse gets to like 80% full, many things stop to register. I send my guys out to get water, chop down trees, they return empty handed.

Things I'd like to see:
1: Grouping of your people- it gets tedious now when I have to sort out 10 people and send all 10 to say, hunting. It'd be nice if I can just create one hunting party and put however many people in it so I only have to click/tap it once to send them on their way.

2: More random happenings. Maybe diseases? Natural disasters? Random strokes of fortune? Maybe things like "The town had a party last night, your people all had fun, for that, they get 100 more energy for the next 10 moves."
something like that. Or things like, "Uncle Bob had an hunting accident and got mauled by a bear, he's in the hospital."

3: I like to see more of the "knight" element. After all, we're supposed to be knight commanders, not slavedrivers :) Maybe random quests like, send Uncle Bob to help nearby town vanquish a beast or monster. Send Uncle Bill to rescue a lost child. etc etc

I'm not sure how the battles work yet cause I've not seen any, but if it's not in, it'd be cool if you can capture enemy people to add them to your party sometimes- likewise, you can lose your own party members as well. That'd add more dynamic to this game.



The problem isn't lack of food, I have lots of food, the problem is lack of time.
Sleeping or eating takes zero energy but 30 seconds time. This means if you do an activity and end up with a person with less than 30 seconds work time left, they're effectively stuck since they can neither eat nor sleep, even if you have a hole lot of food in stock.
Maybe the lullaby or feed all options might work, but it seems rather irritating to have the resources EG lots of food, and no time to be able to use them, plus of course, lullaby and feed all take quite a lot of gold, and when you have two people out of action due to not calculating time correctly it seems a bit harsh (I'm tempted to just restart.

I would suggest myself having an option such as "cat nap" which takes 10 energy and zero time, and restores 30 seconds time and no energy, thus meaning you can then use a more major sleep or food option to get your people usable again.

~Either that or redo the system so instead of sleep and food both taking thirty secons time and zero energy and restoring food and time equallyy, have sleeping take thirty seconds time and restore energy, and eating take 10 energy and restore time, thus meaning your people need to both sleep and eat to keep healthy and that running out of one resource isn't an automatic game block, the way it currently is when you run out of time.

I don't think the speed boost

I don't think the speed boost from shoes is working. I got 100 shoes and the speed doesn't seem to ahve gone up- at least, it still takes the same amount of time to fetch water.

BTW, in case I haven't

BTW, in case I haven't mentioned, the personalize your characters screen is not accessible. It won't let me get out of there or switch to the next character, it just sits on the first character.

Some of the sound effects

Some of the sound effects stop working if you switch to other screens and back again. When I first start the game, my characters talk when I appoint them, but then after awhile if I go to different apps and then come back, they don't talk anymore. I have to close the app and restart it to get them talking again.

The app crashes when I double

The app crashes when I double tap and hold to bring up the context help for the healer task.

I'm not sure if it'll crash for trader and some of the others, most of the context help for tasks works fine.

No idea why it crashes for healer.

An issue for selling items on inventory menu

When I double tap an item to sell in inventory menu and hold it,the item doesn’t decrease but ,the gold will increase.
This mean, you can sell same item as long as you wanted to get more gold.
I hope this issue will be fix soon.

thanks, a nice and easy way

thanks, a nice and easy way to get gold, until it's fixed that is.

Talk about making easy money lol.

I went to so much trouble

I went to so much trouble making massive markets stalls and greenhouses only to find out they don't do anything lol. For that matter, nor does the town clock.
Now also having wood problem, my warehouse is only 39% full and yet when I send my party out to chop trees down, they return with nothing.

They return with nothing

They return with nothing because the amount they collect exceeds what the warehouse can take.

I think there should be a warehouse warning message for tasks like that, like with the energy and time warnings.

I need some beginner tips

I don't know where to actually begin.
I have gone through the tutorial but am not sure how to proceed.

The new version 1.0.24 has

App Developer

The new version 1.0.24 has just been sent to app review.
If it passes the following have been fixed and added.

Added new task Hibernate it will slowly restore full energy and time to work.
This should provide a route out of the dreaded no energy / no time state.

weapon selection is now via a button on the people screen.
Button also contains weapon details for the person
Fix for long press on healer task.
page open sound effect added.
Tools can now be sold.
Fixed long press on sell item.
Added get milk task
Added FAQ
Bugs and Fixes.

This version will need you to restart your game, I tried to code a solution that did not but it would not work. Apologies for this and i will try to make this a very rare thing.

Due to restricted compiler time i have yet to do
war screen

Good luck with the bug hunting.

What device are you using?

App Developer

What device are you using?
The customize layout has buttons below the persons name.

Thank you.

" The customize layout has

" The customize layout has buttons below the persons name."

Iphone 6S with voiceover. Buttons don't show up.


I don't know where to actually begin.
I have gone through the tutorial but am not sure how to proceed."

I started by gathering alot of wood and stones and water to build shops in town heh.


They return with nothing because the amount they collect exceeds what the warehouse can take.

I think there should be a warehouse warning message for tasks like that, like with the energy and time warnings.

IMO returning nothing at all seems silly. If I have 100 space left and they return with 200 woods, the least they can do is fill up my 100 space and then ditch the rest rather than not giving me any lol.

Someone told me there's a

Someone told me there's a "start war" option in shop. That too isn't showing up for me at all- in fact, I been playing 3 days now and have not seen a single combat.

I'm not sure about the whole

I'm not sure about the whole prices going up thing as you increase your energy, warehouse, time ETC.

Eventually something's got to give.

I'm loving the crafting and building aspect of the game, but what's going to happen when prices reach outrageous amounts, like say... a million gold for a warehouse expantion?

You'll just be reduced to building and crafting, trying to make enough to get by.

Hmm, it's starting to sound like the real world lol.