VoiceOver Bug Regarding 3 letter words starting with NO

Club AppleVis Member

Hi all,
I found a little bug with voiceover when trying to read an email and wondered if I was the only one here who experiences this.
Here are the steps to try and reproduce this bug:
Anywhere in iOS, could be a text field or just a page in an app or safari - let's go with a text field to make this easy - type the letters no, make sure they are in lower case. Type any other letter with no spaces between the no you just typed. There should not be any punctuation after this third letter.
So basically you have just typed a 3 letter word starting with NO.
Read the word back by tapping the text field and voiceover doesn't seem to register the third letter of your word.
if you're reading this on an iPhone, voiceover won't read the following correctly.
the word not is spelled N O T, on my phone voiceover just says no for some reason.
The word now is spelled N O W, voiceover just reads it as no again.
I hope this makes sense and please tell me I am not the only one with this confusing problem.


Nope all fine

Hi, No I'm not having this issue. I have a 6S and a 6 both running 9.3.1 and not now in a message field works perfectly fine.

Not here either

iOS 9.3, iPhone 6. I went into notes and first wrote "now", and then "not". I tried with all the English variants in compact, (Daniel, Samantha, Karen, Moira and Tessa), plus alex which is my main voice and in all cases the words were read out correctly. That being said, random text parsing issues with only certain voice types have happened before so it might be helpful if you say which voice and in what quality you're using.

rotor by word maybe?

Club AppleVis Member

it also does it when I use the rotor and navigate by word. You could try that.

same software but with en-uk

Club AppleVis Member

iOS 9.3.1 as well but with Daniel high quality. I think I noticed the bug in 9.3 in the messenger app when it says active now but VO just said active no :)

I got the same bug.

I use the iPhone 6plus on iOS 9.3.1 with Daniel default. When typing the 3 letter word, make sure that there are no capital letters.

Noticed something

Although I haven't seen this bug I've seen Voice over think that Uber is spelled o o b e r for some odd reason and a sighted person confirmed that it's an u.

I also don't have the issue.

I also don't have the issue. Using siri mail voice on an iphone 6.

I know that does not help at all. Have you tried holding down home and power for about 15 seconds to fully reboot the phone?

I have this bug

Hi, I have this bug as well on iOS 9.3 using Daniel on an iPhone 5S. I commented on it on the mane iOS 9.3 posting. Starting to get rather annoying now the more I encounter it which is very regularly. I have re-downloaded Daniel but it does not fix the problem. The bug also occurs with the iOS speech functions outside of voiceover so it may be something to do with Daniel itself.

Yes, it exists

Yes, Even i have realised this bug. I use Daniel Default as my Default voice. Like so many others, I thought, it was only mewho had this issue. Lets hope, they fix it, sooner than later.


Club AppleVis Member

I'm glad I'm not the only one. Now I have received some of your comments, I will look into reporting this bug to apple as over time it is becoming quite annoying.
thanks for all your comments,

Problem with Daniel

I haven't tested this out with other voices, but it doesn't exist with Karen which is my default voice. so it seems that the problem is with Daniel, which might be an issue for the original company to resolve. Tiphlotechnia, I believe, which I probably misspelled.

Looks like it's Daniel

Looks like it's Daniel. For you guys having the issue, try setting your default voice to something else, and perform the same test as outline in the original post. Does it still happen with that voice? If not, it's Daniel.

Daniel, definitely

Club AppleVis Member

Yes the bug is with Daniel, I tried the steps outlined above with all variants of the English voices, high quality enhanced and low quality default. Daniel was the only voice where this bug occurred. In terms of reporting this bug, would it be best to contact Apple, or the company who owns Daniels voice? I might do both, but any suggestions you have would be greatly appreciated.

I would contact apple accessibility

I would contact Apple accessibility, since the voice is used in conjunction with an Apple product. They would probably have to report the bug to Nuance, who produce the Daniel voice. Just explain it exactly how you do here. If they don't respond don't feel bad, because sometimes emails are received but not replied to, and later on you'll find that bugs you reported to them are fixed. It's a weird error for sure.

Since it happens outside of

Since it happens outside of voiceover as well, that might be a bit hard to classify as accessibility and nonaccessibility related. Start with the accessibility department and call them, don't email them.

Take care.

Outside of voiceover

The other speech features that use Daniel like speak selection, speak screen and speak auto text are still controlled under the accessibility section of settings so I would say it is still directly an accessibility related issue.

I would call them and see if

I would call them and see if they can reproduce the issue. I don't use daniel. Not often as he gives me a headache but yea. Good luck.

I have the problem too!

Hello all,
I am using an iPhone 6 with IOS 9.3.1. I am in the UK so default to Daniel enhanced. Until I read this post, I did not remember the problem but now that I have listened for it, I can hear it. The only word it appears to affect is 'now' where you hear 'no' but I will listen out for others. Perhaps other posters are right, it might only be a problem with the Daniel enhanced voice.


I've had this problem too

I noticed it a while ago and then forgot about it. Daniel enhanced pronounced not as no. As I use UK female Siri nearly all the time now I switched to that and it said not correctly. It's definitely a Daniel issue. Is it me, incidentally, or is Daniel regressing generally?

Oh my gosh it's so annoying!

Oh my gosh it's so annoying!
I've had it and didn't realise there was already a thread on it so started my own more recent one. I don't know how or where to report a bug to apple accessibility though.