voiceover reading notifications when screen is locked even though setting is set to off

Hi everyone, I am a relatively new user to IPhone and IOS, so please forgive me if this question has been answered before. Whenever I get a notification like a new mail message, text message, missed phone call etc, and my screen is locked, teh sound for that particular item plays and then voiceover says "one notification" and then the time of day and then a few seconds later, it says "screen locked." Even when my phone is set to mute, it does this. I do have my notifications set to show on teh lock screen but I changed the voiceover setting to not read notifications on the lock screen and this is still happening. Does anyone know how to get voiceover to not read these when the screen is locked? Thank you. I am using an IPhone 5s with the latest version of IOS.

Forum: 

#1 voiceover reading notifications when screen is locked even thoug

Hi, I face a problem while talking on phone, I want the notifications to be on while screen is off but do not want it while I am talking. Is there any solution for this?

#2 voiceover reading notifications when screen is locked

Did you tell it to not show the notifications in notification center?

#3 No, I didn't take them out of

No, I didn't take them out of notification center, but seems like I should be able to have them still be in the notification center adn not talk when the screen is locked but if I wanted to review them I could later.

#4 Turn off View In Lock Screen

Turn off View In Lock Screen if you do not want the lock screen to open. BeLIEVE me there is a big difference between vo reading the time and vo reading an entire unsensored message. Leave sounds on to be alerted to incoming messages. 'for vo on phone calls, use the 3 finger double tap to mute vo during a call. Or us the vo roter to adjust the vo volume during a call so that vo can be used to acess information while on a call. I like "use my headphones to keep vo from making an appearance on my call.

#5 Apparently a bug with IOS8

Just the same question I had with this happening. It is so upseting to my privacy. I don't think there is a fix yet. What I do is turn VO off and then lock my phone. Answering the call becomes very challenging after which.

#6 notifications set to show on the lock screen

Some other thread suggested that you need to turn this setting off on all the apps there. That way notifications will not be displayed on the locked screen and VO will not bother you by reading each notification. I am going to try this on my phone soon...

#7 Resolved

notifications set to show on the lock screen if you choose to disable these it will work just fine. Tried and tested. Settings; Notifications and for each app. just disable it. You will only get the sound alert no VO reading stuff anymore.