VoiceOver speech stops after upgrade to High Sierra.

Apologies if there has already been a post about this, but I was unable to find it.

I got an iMac from a friend yesterday, to replace my 6 year old MacBook, which after being my daily driver, finally died.

All was working well, but the machine was running Mavericks, so I upgraded to High Sierra.

High Sierra has been fine on my old MacBook and the iMac I currently have at work.
VO spoke during the install process, but once that was completed, VO starts but there is no speech.

I have checked and speech is not muted.
VO sound effects play.

I also tried restarting the Mac, but no change.

Before upgrading I was using the Daniel Compact voice and downloading more voices.

I still have Braille, so if this is an issue of no voice being selected for my default language, I should be able to fix it.

However this is pretty annoying. Has anyone else experienced this issue and if so do you know the cause or fix.

Thanks in advance for any assistance.
Jen!

Forum: 

Hi,

Hi,
It almost sounds like the VoiceOver voice volume is muted. Try using the voice rotor, VO+shift+CMD+arrows and change the values until you either hear VO voice come back. If that doesn't work, then try doing a complete clean install on high sierra.

I have read about others with this problem

I have read about several people on Applevis who are having Voice Over speech periodically cut out after upgrading to High Sierra but it seams that the vast majority, including me, are not having any issues. I am very curious as to why some are having the problem and some are not. I don’t want to do anything to my system that might make me start having this problem. It appears that There is no clear pattern as to hardware that is effected. seams that older and newer systems, laptop and desktop are effected but, again, not most of them. Very strange.

Thanks for the help so far!

I will give that a try Justin and report back.

The other problem I have is that the BlueTooth assistant keeps popping up and seems to block the Login screen. Using command q to quit it did not work.

I currently don't have a mouse for this machine, but may buy a second hand Magic Trackpad in future.

Do the VO sound effects and voices now have separate volume controls?

I usually mute the sounds, so I haven't really investigated this before.

I probably won't upgrade the laptop until I have resolved the issue, so at least I will have one working machine until then (hopefully).

Cheers,
Jen!

I don't think the VO sounds

I don't think the VO sounds have a volume control. They're either on or off. Sooo, that should help at least. I never mute the sounds incase this happens.

My solution

Hi Jen,

I upgraded our MacMini server to High Sierra, with the same problem you described.

I checked that VoiceOver was on in System Preferences>Accessibility, as well as checking that VoiceOver wasnot muted and it’s volume is up.

Eventually I created a new user account to see whether the problem was limited to the admin account or was system-wide. VoiceOver worked on this account, so I forced a shut down by pressing-and-holding the power button, and starting up again. VoiceOver worked as normal after that.

In the above steps checking the VoiceOver settings did not help.

I resolved the issue

When are used the voice over rotor, I found the voice was set to automatically detect based on language.
I cycled through the available voices until I got some speech. Perhaps voice-over was trying to use voice that was not actually down loaded yet?
I find it a bit strange that this could be allowed to happen, as surely and if statement could be used to detect voice is present or not and therefore not use it if it isn’t available. Given that I had several compact English voices on my computer, this is pretty astounding. I have no idea finding out what voice it was trying to use, but I might take a look at some logs and send them to Apple.
Does anyone know where I can find the voice-over logs, as it’s been awhile since I had to do any deep dives like this and I can’t remember where/if they are stored.